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Getting Started with HFSS™ 3D Layout: Low Pass Filter

Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

* Procedures are presented as numbered lists. A single bullet indicates the procedure has
only one step.

» Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown (e.g., “copy
file1 ” means type the word copy, then type a space, then type file1).

° On-screen prompts and messages, names of options and text fields, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign > Wave Port.”

o Labeled keys from the computer keyboard. For example, “Press Enter ” means to
press the key labeled Enter.
« ltalic type is used for the following:
° Emphasis.
° The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in

italics (e.g., “copyfile name” means type the word copy, then type a space, then type
the name of the file).

¢ The plus sign (+) is used between keyboard keys to indicate that both keys should be
pressed at the same time (e.g., “Press Shift +F1 " means to press Shift and, while holding
it down, press F1). Always depress the modifier key or keys first (e.g., Shift, Ctrl, Alt, or
Ctrl +Shift), continue to hold it/them down, then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

* The Ribbon occupies the rectangular area at the top of the application window and
contains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Layout > Interface Ground "

ORNONIY

® 1
= [
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

This instruction means click the Interface Ground command from the Layout tab. An
image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

e The menu bar (located above the ribbon) is a group of the main commands of an
application arranged by category such File, Edit, View, Project, etc. An example of a
typical user interaction is as follows:

"From the File menu, select Open Examples" means click the File menu and select
Open Examples from the drop-down menu.

* Another alternative is to right-click and select from the shortcut menu. An example of a
typical user interaction is as follows:

“Right-click and select Assign Excitation > Wave Port” means select an object, right-
click, and click an option from the shortcut menu that appears.

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. This information can also be obtained by contacting an Ansys
account manager.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps are taken
or what stages the simulation reached, including software files as applicable. This allows more
rapid and effective debugging.

Help Menu

From the Help menu, select Help and choose from the following:

* [product name] Help - opens the contents of the help. This help includes the help for the
product and its Getting Started Guides.

* [product name] Scripting Help - opens the contents of the Scripting Guide.
* [product name] Getting Started Guides - opens a topic that contains links to Getting

Started Guides in the help system.
Context-Sensitive Help
To access help from the user interface, press F1 to open the chosen help for the active product.

Press F1 while the cursor is pointing at a menu command or while a particular window tab is
open. In this case, the help page associated with the command or open window is displayed
automatically.
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

1 - Introduction

Complete the Getting Started with HFSS 3D Layout: Low Pass Filter guide to create a low
pass filterin HFSS 3D Layout, then analyze the design as a planar EM solution. The low pass
filter model consists of three layers (i.e., a ground layer, a dielectric layer, and a signal layer).
The user will need to define the layers, assign a custom material to the dielectric layer, draw the
model, define the ports, and set up the solution. After solving the model, the user will review the
S Matrix results, plot the return loss, create a Smith chart, a current density overlay, a far field
display, and animate the results.

e pZ
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HFSS 3D Layout offers several design simulators for HFSS, Planar EM, Slwave, EMI, and
Nexxim. In this topic, learn about the PlanarEm Solution Setup only.

Project Manager o =
= Project13*
54 EMDesign1*
@ Circuit Elements
@ Boundaries
Excitations

m-yl Deesign Paste Ctrl+V
~Eloetmet 4y eSS Solution Setup .. >
----- Results

' Add HF5S Custorn Setup ...
----- Field O
_____ Radistio B8 Add Planar EM Solution Setup ...
-] Definitons [+  Add Slwawve Solution Setup ..
E Add Slwave DCIR Sclution Setup ...
E Add EMI Scanner Setup ...
Add Mexxim Sclution Setup... »

Add Mexxim Solution Options ..
&8 Analyze F10
Generate Mesh

Invalidate Solutions

22| Browse Solutions...
e ——— Clean Up Solutions...
Properties Import Solution... F =
Update Menu ‘ ‘

EM Design simulators are the ideal tools for projects that involve full-wave or radiative effects for
multilayered structures. For example, draw the physical layout of a patch antenna or a
millimeter-wave integrated circuit and simulate the electromagnetic properties to display the
following:

+ Radiated electric fields

Basic electromagnetic field quantities

Characteristic portimpedances and propagation constants

Basic far-field parameters for electromagnetic fields and antennas

Generalized S-parameters, and S-parameters renormalized to specific port impedances

For more information see the HFSS 3D Layout Simulator in the main help.
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The following topics cover the physical design and EM analysis of a low-pass filter, specifically
the following subtopics:

* How to start Electronics Desktop and explore the HFSS 3D Layout tools

How to use the HFSS 3D Layout ribbon, menu, and shortcut menu

Terms and concepts essential to the simulation of an HFSS 3D Layout design

How to add a custom-defined dielectric material to a design

How to create a report to display simulation results

Setting General Options

Before inserting an HFSS 3D Layout Design into the project, ensure the Electronics Desktop
options are set appropriately for this exercise.

[ —
1. From the Desktop ribbon tab, click General Options.

2. Inthe tree on the left side of the Options window, expand the General group and select
the Default Units subgroup.

3. Ensure mm is selected on the Length drop-down menu to use millimeters as the default
length unit.

4. From the Options tree, select the Layout Editor> Snapping subgroup.

5. Under Targets, clear the Grid option and ensure that your other selected options match
the following settings:
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6. From the Options tree, select the Layout Editor> Display subgroup.
7.

Opticns

20 Extractor

Circuit Design

Circuit Metlist Design

EMIT

HFS5

HFS5 30 Layout

Icepak

Maswell 20

Maxwell 30

Mechanical

Q30

RMxprt

Twin Builder

30 Modeler

E Layout Editor
Object

[+

FHEHEEBBEH

Display
Selection
Other
Advanced
Machines

sropring SR

Constraints
[~ Snap to grid

|+ Snap across hierarchy

Directional constraint
{* Mone
" Orthogonal  (Key:r)

(Key: n)

" 45degree (Key: d)

Distance

20 _|::| Pixels

Targets
Cursor Indication
v Wertex

|v Edge center

v Object center

[ Any edge location
Iv Electrical connection

| Edge intersection

|_L>)Grid

St x =0

Sources

¥ Vertex

[v Edge center

v Object center

[ Any edge location

[v Electrical connection

In the Grid field, enter 10 mm for Major and 1 mm for Minor, making sure the unit used
for each is millimeter (mm), the default setting.

Options

HFS5
HFS5 30 Layout
HFS5-1E
Icepak
Maxwell 2D
Maxwell 30
Q3D
RMxprt
Twin Builder
3D Modeler
= Layout Editor
Object
Snapping

Selection

Other

Advanced
Machines

S Grid
Color Size

N —

Background: |

Iv Show grid divisions

Drawing
{+ Default
{" Sketch
{ Solid

Major divisions: | | 10mm A number without units is

interpreted as having

Minar divisions: | | 1mm units of "mm®, the

current default length
units.

Drawing extent

Left: |-100mm Top:
Right: | 100mm Bottom: | -100mm

8. Click OKto close the Options window.
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Enabling Legacy View Orientation

The instructions and examples in this guide use the legacy view orientation scheme, rather than
the controls introduced in release 2024 R1. Complete these steps to enable the Legacy View

Orientation and avoid any confusion.
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1. Navigate to Tools > Options > General Options to open the 3D Ul Options window.
Tools  Window Help

) Edit Libraries b i B E
) Library Tools 4 @ cColorby ~
Project Tools 4 EHiGrid
Toolkit * lupport

Run 5cript...

Record Script To File...
Record Script to Project...

Open Command Window
Password Manager...

Debug Logging...

Options g General Options...
Keyboard Shortouts... iy HPC and Analysis Options...

External Tools...
Export Options Files...

Show Queued Simulations

B =

Edit Active Analysis Configuration...
Import Array from Table...
Job Management L4

Calibration Wizard

Diagnostics L4
Chip Model Analyzer [CRhA]

Layout Links...

SPISim

Filtersolutions

Metwork Data Explorer

PEmag...

2. Expand General and select User Interface.

3. Check the Enable Legacy View Orientation box. When the user has completed the
Getting Started Guide, they should return to Options window and uncheck the Enable
Legacy View Orientation box.
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Opticns

[E General
Desktop Configuration
Project
Miscelaneous
Directories
Desktop Performance
Default Units
Remote Analysis
Component Libraries Options

2D Extractor

Circuit Design

Circuit Netlist Design

EMIT

HFS5

HFS5 30 Layout

Icepak

Maxwel 20

Maxwel 30

Mechanical

Q30

RMxprt

Twin Builder

30 Modeler

Layout Editor

Machines

Model Editor

Metist & Serint Fritor

[#

#FFEFFEBEBEEEBBB

General
[ Show Message Window on new messages
I¥ Ensure that new messages are visible in the Message Window Tree

[ show Progress Window when displaying progress bars

Project Tree Visualization Options
[¥ Emphasize active command context (menu and toolbars)

I¥ Change icon when selection does not match active window
Mote: Single dick icon to launch corresponding window if available

| Expand Project Tree on Insert

Display Options
Maximum MNumber of Significant Digits a

Color scheme: Classic ﬂ
[¥ Enable Legacy View Navigation

[ Show welcome message at startup

0K | Cancel

4. Click OK.

Create the Model

From here, continue to the following topics to define the stackup layers (i.e., topology) of the
model, draw the geometry of the filter, and assign the excitation ports.

* Insert Layers
¢ Draw the Model Geometry
¢ Assign the Ports

Insert Layers

Complete these steps to insert layers in an HFSS 3D Layout design.
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1. From the Layout tab, click the Layers dialog button to open the Edit Layers window.

] - EMDesign1 -
§ [ ratch .
it Simulation Results Autor

§ Layers dialog
Ite Open layers dialog
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Note:

Alternatively, from Layout, select Layers.

Layout HFS55 3D Layout Teocls Window Help

BE List...
ﬁ Layers...

Mets

Push Down
Pop Up

Place Design...
Snap 3D

Connect Pins...

@,’ Cutout

[BETA] Generate Suggested HF55 Regions for Shwave
Group into Subdesign
30 Compenent Definitions
Import
Export
Cross-Probe Schematic
% Settings...

Grid settings...
Draw HF55 Air Box

aa
=]

E

Draw Ports/Sources

WiaStyles...
PinStyles...
Line Styles...
Text Styles...

Export to Slwave with ALinks

fm Measure

Erase Measurements

Ctrl+K
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2. If appropriate, select Laminate from the Stackup area > Type drop-down menu.

Stackup
Type: | Laminate j

Units: |5 erapping
Multizone [Beta]

Add a Ground Layer to the Grid Control Table

Note:

When adding the first layer to the layers table, the actions of Insert above and Insert
below are identical. Once there are one or more layers in the table, the Insert above
and Insert below options will be inactive until a layer is selected from the Grid
Control Table. After selecting a layer from the table, select the chosen option
depending on where you would like the new layer to appear in the table (i.e., above or
below).

1. Click Layer and select either Insert above or Insert below to open the Add Stackup
Layer window.

Layer Zone
Insert above...
Insert below...

Remowve

2. Inthe Add Stackup Layer window, do the following:

Add Stackup Layer *

M ame: || k. |
Type: |signal j Cancel |

Thickneszs: |Dmm

M aterial: | COppET ﬂ
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a. Enter g1inthe Name field.
b. Select signal from the Type drop-down menu.
c. Click OKto close the Add Stackup Layer window add the new infinite ground layer to

the Grid Control Table.
Note:
The material copper is automatically assigned to signal layers.
3. If appropriate, add the Negative column to the table. Right-click any column header (e.g.,

Material, Type, or Name) to open the shortcut menu. Then select Negative. The
Negative column will appear in the table.
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[ = [= [ [ 0= |= | nq
E " Wireframe
~ Visibility
~  Shape visibility
~  Line visibility
~  Pad visibility
" Hole visibility
~  Component visibility
+~  Mame
v Type
~  Megative
~  Material
«*  Dielectric Fill
Dielectric Constant
1 Loss Tangent

" Thickness
Evaluated Thickness

- Top bottorn asscciation

~  Etch
r ~  Rough
~  Solver
Lower
Upper

Evaluated Lower
Evaluated Upper
Pattern

~  Transparency

4. Check the box in the Negative column.
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Note:

Checking the box in the Negative column identifies the layer as a ground plane
layer. Any object drawn on a negative layer becomes a cutout in the ground layer
(conductor removed). However, no objects can be drawn from the g7 layer for
this model.

5. Ensure the box in the Rough column is not checked.

Note:

If the Rough box is checked, the surface roughness of the conductors is taken
into account when approximating the impedance of the signal traces. However,
surface roughness is ignored for ground layers. Removing the check from the
box in the Rough column prevents a warning to that effect during validation and
solution setup.

Add a Dielectric Layer to the Layer Table

1. Right-click anywhere in the g1 layer and select Insert dielectric above. A new row
appears in the layer table (default Name, Dielectric).

Insert above...

Insert below...

Insert signal abowve
Insert signal below
Inzert dielectric abowe
Insert dielectric below

Insert Via Layer
Remowve

Lock
Unlock

Set Active

Merge Dielectrics...

Zones
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2. Inthe new dielectric row, do the following:
a. Inthe Name field, replace dielectric with d1.
b. Ensure 1.6mm is entered in the Thickness field.
c. Select Edit from the Material drop-down menu to open the Select Definition window.

Material |Thickness Etch | Rough | Salver | Lower Evaluated Lower | Evaluated Upper | Transparency

Select Definition *

Materials ] Material Filters

Search Parameters
Search by Name Search Criteria Libraries W Show Project defintions [~ Select all libraries
| @ by MName (" byType ¢ by Property | [[sys] Materials
|Re|ative Permittivity J
Relative Relati A
f Mame Location Crigin Type Permittivity Pemmes
1
FR4_epoxy SysLibrary Materials Dielectric 44 1
n gallium_arsenide SysLibrary Materials Dielectric 1259 1
GE GETEK ML2D0/RG200 ¢m) SysLibrany Materials Diglectric 15 1
GIL GML1000 gtm) SysLibrany Materials Diglectric i1z 1
N GIL GML1032 ¢tm) SysLibrany Materials Diglectric 12 1
GIL GML2032 ¢tm) SysLibrany Materials Diglectric 12 1
GIL MC5 ¢m}) SysLibrany Materials Diglectric 12 1
N glass SysLibrany Materials Diglectric 55 1
glass_PTFEreinf SysLibrany Materials Diglectric 25 1
N gold SysLibrany Materials Perfect conductor 1 0.95556
N graphite SysLibrany Materials Diglectric 1 1
HDPE plastic SvsLibrarv Materials Dielectric 23 1 "
4 >
View/Edit Materials... Add Material .. Clone Material(s) Bemove Material(s) | Export to Library... |

0K | Cancel | Help |

3. Inthe Select Definition window, do the following:
a. Click Add Material to open the View / Edit Material window.
b. Inthe Material Name field, replace Material1 with my_d1.
c. Inthe Relative Permittivity Value field, replace 1 with 2.2.
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d. Click OK to save changes, close the View / Edit Material window, and return to the
Select Definition window.

B8] view / Edit Material

Material Name
‘my_d1

Properties of the Material View/Edit Material for

f+ Active Design
Relative Permittivity

" Active Project

Relative Permeability 1
Bulk Conductivity Simple 0 siemensfm " All Properties
Dielectric L T t  Simpl 0
ielectric Loss Tangen imple Physics:
Magnetic Loss Tangent  Simple 0 =
-
-

View/Edit Modifier for

[ Thermal Modifier
=

Material Appearance

[ Use Material Appearance

Motes

Set Frequency Dependency... ‘ |Calculate Properties for: J

Validate Material

Reset | 0K Cancel |

e. Click OK to close the Select Definition window.
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Add a Trace (Signal) Layer to the Layer Table

1.

2.

Right-click the d1 layer and select Insert signal above. A new row appears in the table.

Insert above...

Insert below...

Insert signal abowve
Insert signal below
Insert dielectric abowve
Insert dielectric below
Insert Via Layer

Remowve

Lock
Unlock

Set Active
Merge Dielectrics...

Zones

In the new signal row, do the following:
a. Inthe Name field, replace Signal with t1.
b. Check the box in the Rough column.

Make Changes to All Layers

1.

Ensure the Solver option is deselected for all layers. Default solver options are not
overwritten.

Saolver

=
-
—
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

Note:

By default, Select all is chosen in the Layer area drop-down menu, but if the
rows in the layers table are not highlighted, the layers are not actually selected.
To complete step 4, click from the Layer area drop-down menu and choose
Select All again. The rows willimmediately be highlighted.

Edit Layers - EMDesign

Stackup Layer Zone

Primary
Dizplay Stackup
{* Stackup layers Type: Im g
" Mon-stackup layers .
 Alllayers Units: |mm hd
=] [ ] ] [] [ L) *

Name Type Negative | Materal | Dielectric Fill | Thickness Etch | Rough | Solver | Transparency

Layer

Insert above... Edit selected
Visibility Attributes Analysis
Name:
Insert below... v

e | e e

S [ N

<] <
a
-

<
<
|
m

<
-
1]

<l <]

[ I =]
g
=
=

Thickness:
Top bottom:  |neither -

Total height: 1.6mm

2. From the Layer area, choose Select all from the drop-down menu.

3. Ensure the "shading" box in the Attributes area (i.e., the middle box) is checked. This
ensures that all objects will be shaded, rather than only outlined (wire frame).
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Attributes

_j_ 60%

4. The Edit Layers window should now match the following example.

Edit Layers - EMDesign1

Stackup Layer Zone

Prmary
Display Sackup
@ Stackup layers Type: [amnze =] @
" Norvstackup layers
¢ Allores vnis fom <]
S0 oo

Layer

nsert above.. Edt selected

Visbity | |- Abutes Anaiyss
Insett below R
= v =

e | ||w= B g ||F o
e | | S |Fe |[Fa -
¥ @ ra g
NN ==
Thekness | | oo |

Top bottom: [reither -

Total height: 1.6mm

Apply and Close Aprly Close

Note:

If the stackup is not arranged in the correct hierarchy, rearrange the layers by
clicking+dragging the selection handles in the left column. The t1 layer should
be from the top of the list, followed by the d1 layer in the middle, and the g1 layer
from the bottom.
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

5. Click Apply and Close to apply the layer definitions and close the Edit Layers window.

Continue to Draw the Model.

Draw the Model

Complete these steps to draw a model in the Layout Editor.

1. From the Layout tab, select t1 from the Active Layer drop-down menu:

[M] - EMDesign1

§ (D

I 1

Lt o I g 1
[ 5lwave Regions
I zasures
I F et
I Errors
I =y mbols
I e mbly
[ silkscreen
[ Postprocessing
I Cutline

(e m—

2. Fromthe Layout tab, click Draw rectangle.

mae AR SO
O R ® =

PA[Nv|-|L|O®

[ Draw rectangle
Drraw rectangle primitive
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Note:

Alternatively, navigate to Draw > Primitive > Rectangle.
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P2 R1 - Project13 - EMDesignl - Layout - [Project13 - EMDesignl - Layout]
Draw Layout HF5530 Layout Tools Window Help

i Primitive > T Arc
L Void > @ Circle
Merge Polygons > 5y Line
Port , [ Rectangle
Boundary > & EEhGE
o Pin [P Bondwire
:;(E Create/Manage Pin Groups... A Text Ctrl+T
T Via “p 3D Line
Via Groups > [
30 Structure -]
Coordinate System ¥
Component ¥
Rotate Ctrl+R
Flip Vertical

Flip Horizontal
Reverse Line
Align...

Position Relative

Clear Relative Position

Duplicate ¥
Expand
Split Polygon Region
g‘ Geometry Healing...
B8 Sanitize Layout...
I Conwvert ¥
[ Stitch Lines

Connection Crl+W
Dizconnect from Met

1 Align MW Ports Ctrl+M
Cross Section for W-element Analysis

£ Cavity...

= Plane Wave Excitation

HF55 30 Layout Properties ¥
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

3. Do not click+drag in the Layout Editor. Instead, move the cursor to the X coordinate
field at the bottom of the Layout Editor. Click inside the field, delete the coordinates
already present, and enter 0.

4. Press Tab to move the cursor to the Y coordinate field. Then type 0 in the field and press
Enter.

5. Either press Tab until the cursor moves to the Delta X coordinate field or move the cursor
to the field, click inside it, and enter 20.

6. Press Tab to move the cursor to the Delta Y coordinate field, Then type 4.6 in the field and
press Enter to complete the shape.

20,0000 .0000  palta X 200000 | pegs ¥ 4.4
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Note:

Alternatively, create a rectangle to the exact dimensions required by first creating
arectangle of any size, in any location, and then modifying its perimeters in the
Properties window. For example, to create the rectangle described previously,
do the following:

a.
b.
C.

From the Layout tab, click Draw rectangle.
In the Layout Editor, click+drag to draw a rectangle.

Select the newly-drawn rectangle to display its perimeters in the Properties
window.

In the Properties window, do the following:
i. Ensure the 2 pt Description box is checked.
ii. Enter0, 0inthe Pt A field.
iii. Enter 20, 4.6 in the Pt B field.
iv. Press Enter to save changes.

Properties I =
Name | Value | Linit | Evaluated Value
Type rect
Mame rect_24
Lock Position [
Placement Layer t1
Met e
Megative [
2 pt Description [w
Pt A 0.0 mm Omm , Omm
Pt B 2046 mm 20mm |, 4 6mm
ComerBadius 0 deg (Odeg
Angle 0 deg Odeg
Footprint
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7. Create a second rectangle by doing the following:
a. From the Layout tab, click Draw rectangle.

b. Hover over the lower-right corner of the first rectangle until the cursor turns into a
square when the snap point is found. Then click to snap the first corner of the second
rectangle to that point. This effectively designates the X, Y coordinates for the second
rectangle, as if this position were 20, 0.

c. Clickinside the Delta X coordinate field, delete the coordinates already present, and
enter 2.1. Then press Tab.

d. Type -10.5in the Delta Y coordinate field and press Enter.

8. Create a third rectangle by doing the following:
a. From the Layout tab, click Draw rectangle.

b. Either hoverin the Layout Editor and press Tab to move the cursor to the X
coordinate field, or move the cursor to the field and click inside it. Enter 21.05 in the
field, then press Tab.

c. Type 0intheY coordinate field, then press Enter.
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d. Either press Tab until the cursor moves to the Delta X coordinate field, or move the
cursor to the field and click inside it. Enter 21.7 in the field, then press Tab.

e. Type 0.7 in the Delta Y coordinate field, then press Enter.

Click anywhere else in the Layout Editor to clear the current selection.

. Zoom In from the space between the right edge of the first rectangle, the top edge of the

second rectangle, and the left edge of the third rectangle, by doing one of the following:

Spin the mouse wheel to Zoom In/Out.

Press Ctrl+D.

From the Layout tab, click Fit All.
From View, select Fit All.

From the Layout ribbon, select Zoom > Zoom Area. Then click+drag the mouse to

define an area.

-Qh- Pan
s Rotate

Zoom
- . Orient -

Zoom
Zoom Area
Zoom In

Zoom Qut

D oOPEO

Zoom Previous

Fit All

((E)]
1n/y

Ctrl+C

Introduction 1-25

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.




Getting Started with HFSS™ 3D Layout: Low Pass Filter

11. Create a polygon by doing the following:

Note:

During step c, the cursor may become a triangle, since the snapping point
corresponds to the midpoint between the second rectangle's top edge and the
end point of two of the third rectangle's edges.

a. From the Layout tab, click Draw polygon.

b. Hover over the upper-right corner of the first rectangle until the cursor
turns into a square when the snap pointis found. Then click (values
displayed in the X, Y coordinate fields will be 20.0, 4.6).

c. Click the upper-left corner of the third rectangle (values displayed in the X,
Y coordinate fields will be 21.05, 0.7)

d. Click the lower-left corner of the third rectangle (values displayed in the X,
Y coordinate text fields will be 21.05, 0.0)

e. Double-click the lower-right corner of the first rectangle (values displayed
in the X, Y coordinate text fields will be 20.0, 0,0)
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12. Press Ctrl+D to fit the drawing in the Layout Editor and clear the current selection.

13. Create duplicate copies of the first two rectangles and the new polygon by doing the
following:

a. Press Ctrl+A to select all the objects.

b. While holding down Ctrl, click the third rectangle to deselect it. The first two rectangles
and the polygon should still be selected.

c. Press Ctrl+C to copy the selected objects.

d. Press Ctrl+V to paste a duplicate set of objects into the Layout Editor. The location of
the pasted objects moves as the mouse is moved.

e. Choose an area in the Layout Editor that does not overlap the original objects. Then
click to drop the new objects. Ensure the new objects remain selected for the next
step.
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14. From the Layout tab, select Flip > About Y (or, from Draw, select Flip Horizontal).

an 7o - i [
A AboutY
&= AboutX

15. Click+drag the selected objects to align with the bottom right corner of the third rectangle.
Once the cursor becomes a square, release-click and the objects will snap into place.

16. Press Ctrl+D to fit the drawing in the Layout Editor and clear the current selection.

17. Create a fourth and final rectangle by doing the following:
a. From the Layout tab, click Draw rectangle.

b. Either hoverin the Layout Editor and press Tab to move the cursor to the X
coordinate field, or move the cursor to the field and click inside it. Enter 29.3 in the X
coordinate field, then press Tab.

c. Type 0intheY coordinate field, then press Enter.
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d. Either press Tab until the cursor moves to the Delta X coordinate field or move the
cursor to the field and click inside it. Enter 5.3 in the field, then press Tab.

e. Type-10.5inthe Delta Y coordinate field, press Enter.
18. Press Ctrl+A to select all objects.

Note:

It is not mandatory to unite the individual shapes. Where they meet, the solver
treats them as a contiguous object, regardless. However, uniting them produces
a simpler model and eliminates the possibility of accidentally dragging one shape
out of its proper position.

19. From the Layout tab, select Unite to form all the rectangles and polygons into a single
object.

[P Unite  [jDuplicate = gl Flip ~
B, Subtract '!!E Cornwvert = D,D«‘-" Rotate
@ Intersect gReuerse Line D’hﬁlign

G Union

Union polygons

20. The design should match the following figure.

21. Click the object to select it. From the Properties window, replace the text in the Name
field with Filter. Then press Enter to save changes.
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Properties 7 x
Name [ Value [ unt [ Evaluated value ~

Type poly

Name Fiter

LockPostion r

FlacementLayer 1

Net —

Negative -

Ft0 447 105 mm | 44.7mm ,-10.5.
Pl 4470 mm | 44.7mm . Gmm

Fi2 647 0 mm | 64.7mm, Omm

Pt3 647 46 mm |64.7mm . 4.6mm
Pt 447 46 mm | 447mm, 4.6mm
Pt5 43207 mm|43.2mm . 0.7mm
Pt6 21507 mm | 21.5mm . 0.7mm
Fi7 2045 mm | 20mm , 4 6mm

Pt8 045 mm | Omm ., 4.6mm

Fi3 0.0 mm | Omm, Omm

FtiD 20.0 mm20mm . Omm ¥
< >
Footpiint |

22. Save the design, either by navigating to File > Save or clicking the Save button on any of
the ribbons.

wl

Save

Continue to Assign the Ports.

Create Edge Ports

Complete these steps to add two edge ports to the model.
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1. To create the first port (i.e., Port1), do any of the following:
* Press E to enter Select Edges mode.
* From the Layout tab, click Select edges > Select Edges.

M] - EMDesign1 - % Pan

& i s Rotat
- Zoom
T « [ crien
i R Select 0
Select Handles H
“w  Select Edges E
HE  Select All Ctrl+A
Unzelect All Ctrl+5Shift+ 4

Cycle Selection
|nvert Selection

K Select by Polygon Region

Select Physically Connected

Select Met Connected
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

* From Edit, click Select Edges.

Edit View Project Draw Layout HF55 3D Layq

Undo Ctrl+Z
(¥ Redo Group Ctrl+Y
Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V
Delete Delete
Rename F2
B Select All Ctrl+A
Unselect All Ctrl+Shift+ A4
Cycle Selection B

Invert Selection

Ni  Select by Polygon Region

Copy Image
Copy to HFS5 3D Layout
Paste in Place Ctrl+5Shift+Y
h Select 0
Select Handles H
"%y Select Edges E
Properties...
Note:

Once Select Edges is chosen, the cursor changes: a diagonal line crosses the
tip of the arrow. Refer to the following step.
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

2. Click the left side of the leftmost rectangle to select it.

3. Toadd the first port to the leftmost rectangle, do one of the following:
« From the Layout tab, select Create edge port.

L | & & | ¢ [P unie
e 1 K subtract W3
:' [T Intersect 2

U:. Create edge port

Create edge port from current edge
selection

* From the Project Manager window, expand the Project Tree and [active design
folder]. Then right-click Excitations and select Add Port.

Project Manager 1

=3 GETSTART*

548 EMDesign1*
@ Circuit Elements
@ Boundaries

- 23]

o988 Analysie [l Add Port

m"l Design I"'I'_Eri Add Plane Wave Excitation
gz:jtestncs Couple Edge Ports
_____ Field COverl: Decouple Edge Ports
- Radiation Convert Selected Vias to Coax Probes...
[-( Definitions A Port Excitations...
Ellm Project1s™ Differential Pairs...

& EMDesign1*

: Reorder Matrix...
-ZJ Definitions sarder vt

Select in Layout
Delete All
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 From Draw, select Port > Create.

Draw Layout HF5530 Layout Toocls Window  Help

Primitive > @ Fit Al - T
Void * [CL Fit selected | @ ~
Merge Polygons * EH$

Port ¥ U_—. Create

Boundary * Rermowve

Pin

Create Circuit Ports
Create/Manage Pin Groups...

el K49

Assign Reference

ORI

Yia

Via Groups - Clear Reference

30 Structure y Couple Edge Ports
Coordinate System 7 Decouple Edge Ports
Component » Coax Probe...

Rotate Ctrl+R

Flip Vertical

Flip Horizontal
Reverse Line
Align...

Position Relative

Clear Relative Position

Duplicate *
Expand

Split Polygon Region

Geometry Healing...

%

Sanitize Layout...
Conwvert *

Stitch Lines

Connection Ctrl+W

Disconnect from Met

Align MW Ports Ctrl+ M

p B
?-l-l

Cross Section for W-element Analysis

&1 Cavity...

Plane Wave Excitation

HF55 30 Layout Properties *
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* Right-click in the Layout Editor and select Port > Create.

k Select 0
Select Handles H

"t Select Edges E

f} Cycle Selection E

(¥ Unselect Al Ctrl+Shift+A
List Selection...
Push Down
Pop Up
Place Design...
Snap 3D
Connect Pins...
Port > U;. Create
Boundary * Remove
DEIR Create Circuit Ports
Interface -]
Nets 5 Assign Reference
Irrwes y Clear Reference
30 Compenents * Create Ports on MNet
Layout Components ] Remove Ports From Met
Padstack... Create Ports on Component ...
Footprint... Rernove Ports From Component
Wiew ] Create Pin Group
Draw » Couple Edge Ports
Edit g Decouple Edge Ports

Coax Probe...
Copy Image .
HFSS 30 Layout Properties »
Note:

Once a portis created, it appears in the Project Manager > Project Tree >
[active design folder] > Excitations folder.
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4. Create the second port (i.e., Port2) by doing the following:
a. If appropriate, press E to re-enter Select Edges mode.
b. Click the right edge of the rightmost rectangle to select it.

1

c. Fromthe Layout tab, select Create edge port.

L | & & | ¢ @unite [
1 [ subtract W3

:_1‘-_':
— [ Intersect i

L
L

L, Create edge port

Create edge port from current edge
selection

5. Rename Port 1 by doing either of the following:

* From the Project Manager window, expand the Project Tree > [active design folder]
> Excitations folder. Then right-click Port1, select Rename, and replace Port1 with

p1.
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Project Manager

=3 GETSTART*

548 EMDesign1*
@ Circuit Elements
@ Boundaries
=-{F3] Excitations

- BYrort1

=568 Analysis
E"I Design Ve
l@ Optimetric
----- Results
Field Qver
Radiation
[-/_7 Definitions
=34 Project15=
-4l EMDesign1*

Rename F2
Delete Delete
foom To

Properties..,

Via Properties...

Add Reference
Remove Reference

Decouple Edge Port

I:l Definitions

Select in Layout

« From the Project Manager window, expand the Project Tree > [active design folder]
> Excitations folder. Then click Port1. From the Properties window > Port Value field,
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replace Port1 with p1, then press Enter.

Properties o x

MName Value| Unit | Evaluated Value |

Fort Bl

Boundary ... |Port

Reference

Impedance (50  ohm 50chm
Magnitude |1 W i\
Phase 1] deg Odeg

Renomalize | v
Renomali... |50 +...|ohm 50chm + 0i ohm

Deembed... | |
PlanarEM

Type Slat ...
HF5S

HF55 Type ™"In...

EM Design

Introduction 1-38
Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™ 3D Layout: Low Pass Filter

6. Repeat step 5to rename Port2 to p2.

Project Manager 3 =

=3 GETSTART*

L-é EMDesignl*
@ Circuit Elements
@ Boundaries

[—]@ Excitations

7988 Analysis
E". Design Verification
l@ Optimetrics
----- Results
----- % Field Overlays
----- ? Radiation
[#-_7 Definitions
=3 Project15*
-4l EMDesign1*
-2 Definitions

I+

Continue to Set Up a Planar EM Analysis.
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2 - Set Up Solution and Analyze

This chapter contains the following topics:

+ Set Up a Planar EM Analysis

+ Set Up Frequency Sweeps

» Explore Disabling Sweeps and Setups
* View the Mesh

e Explore Dynamic Mesh Updates

¢ Run the Analysis

Set Up a Planar EM Analysis

Solution Setups are listed in the Project Manager window (i.e., expand the Project Tree >
[active design folder] > Analysis folder). To add a new solution setup to this project using
basic, initial meshing tools, follow these steps.

1. Open the PlanarEMSetup window by doing one of the following:
* From the Simulation ribbon tab, click PlanarEM (Add Planar EM Solution Setup).

LR SR8 ¥ v

HFSS Slwave DCIR EMI PlanarEM Sweep Optlmetrlcs Validatq

it Simulation Results Automation Ansys Minerva

i | Add Planar EM Solution Setup
! Insert a Planar EM solution setup

for circuit analysis
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¢ Right-click Analysis in the Project Manager window and click Add Planar EM
Solution Setup .

Project Manager J;I

=HE GETSTART

L-é8 EMDesignl

@ Circuit Elements
@ Boundaries

-1 Excitations

- 8%
m-i' Design Ve Paste Ctri+V

{78 Optimetri
_____ Results Add HFS5 Selution Setup ... >

..... Field Qve Add HF55 Customn Setup ...
----- Radiation ER  Add Planar EM Solution Setup ...
f-(] Definitions Add Slwave Solution Setup ...

=3 Project15= _
& EMDesign 1+ [¥8  Add Slwave DCIR Solution Setup ...

i (] Definitons 8 Add EMI Scanner Setup ...
Add Mexxim Solution Setup... >

Add Mexxim Solution Options ...

& Analyze F10
Generate Mesh
Invalidate Solutions
Properties @ Browse Solutions...
Clean Up Solutions...

- Import Solution...

Update Menu

¢ From HFSS 3D Layout, select Solution Setup > Add Planar EM Solution Setup.
2. From the PlanarEM Setup window > Mesh Selection area, do the following:
* Ensure Fixed Mesh is selected.
+ Enter 5in the Solution Frequency field.
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PlanarEMSetup

Setup Name:

Mesh Selection
Fixed Mesh

Solution Frequency:

[ Use edge mesh
v

~

General lOptiu:uns ] Advanced ] Advanced Meshing ] Suluer] Defaults ]

|F‘IanarEI"-'1 Setup1

[v Enabled

Standard Adaptive | Advanced Adaptive |

E lGHz ~|

1000.0000mm

se Defaults |

HPC and Analysis Options. ..

Cancel

o |

3. Click OK to close the PlanarEM Setup window and open the Edit Frequency Sweep

window.
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Edit Frequency Sweep *
Edit Frequency Sweep ] Interpolation |

Sweep Name: |[ETEEl [+ Enabled

Sweep Type: | Interpalating ﬂ

Freguency Sweeps [401 points defined]

Distribution Start End

Bl Linear Step

Add Above Add Below Preview ... |

Time Domain Calculation... |

QK | Cancel

Continue to Set Up Frequency Sweeps to define the frequency sweep.

Note:

For more information on setting up an HFSS simulation, see Add HFSS Solution
Setup in the product Help.

Set Up Frequency Sweeps

Complete these steps to add, set up, and define either an interpolating or discrete frequency
sweep.
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Note:

If this topic is reached in succession after completing the steps in Set Up a Planar EM
Analysis, the Edit Frequency Sweep window should still be open. If the Edit
Frequency Sweep window is open, skip to step 2.

Edit Frequency Sweep >
Edit Frequency Sweep ] Interpolation ]
Sweep Name: (SN0l ¥ Enabled

Sweep Type: | Interpolating ﬂ

Frequency Sweeps [401 points defined]

Distribution Start End

1M | inear Step

Add Above Add Below Preview ... |

Time Domain Calculation... |

Ok | Cancel |

Add an Interpolating Frequency Sweep

1. From the Project Manager window, expand the Project Tree > [active design folder]
> Analysis folder to view the analysis setup (e.g., PlanarEmSetup1). Then add an
interpolating frequency sweep associated with a Planar EM solution setup by doing one of
the following:
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» Create a solution setup and the Edit Frequency Sweep window automatically appears
(see Set Up a Planar EM Analysis).

» Select the analysis setup (e.g., PlanarEmSetup1). From the Simulation tab, click Sweep
(Set Up Frequency Sweeps) from the ribbon.

LREER@8R - ¥ vV

HF55 Slwave DCIR EMI  PlanarEM Sweep  Optimetrics Validate Analyzd

-

it Simulation Results Automation Ansys Minerva

— 5et Up Frequency Sweeps

f ___f Setupfrequency sweeps for
HFS55 30 Layout analysis

» Select the analysis setup (e.g., PlanarEM Setup1). From HFSS 3D Layout, select
Solution Setup > Add Frequency Sweep.
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HF55 30 Layout  Tools  Window  Help

Design Settings... EEE Active: Local -

Add Subcircuit 5 = BB analysis Config
FRerE alidate Analyze HPC

oL Opti
|":"|I:JI Port Excitations... ptions

Differential Pairs

Reorder Matrix... |
Solution Setup > Add HFSS Selution Setup... -]

Optimetrics Analysis , B Add Planar EM Solution Setup...
] HFSS Extents L+  Add Shwave Selution Setup ...
BB Lt E Add Slwave DCIR Selution Setup ...
Q_g Validation Check... EE Add EMI Scanner Setup ...
@ e T Add Mexxim Sclution Setup... ]
B Edit Notes Add Mexxim Sclution Options ...
B Analyze F10 | Add Frequency Sweep...
"% Tune.. Pre-Process Geometry ¥
submit Job... F[l] Co-Simulation Options...
P
S , ——

Hﬁ’ﬁ Layout Editor

Schematic >
E| Estimate...
B’ CloseEditors

Convert Geometry to Vias...

Select In Layout
Set Ternperature

Design Properties...
Design Passed Parameters...

Design Datasets...

Toolkit ¥

« Right-click the analysis setup (e.g., PlanarEMSetup1) and select Add Frequency
Sweep.
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Project Manager

=HEY GETSTART*

548 EMDesign1*
@ Circuit Elements
@ Boundaries
=-{F3] Excitations

=58 Analysis

...... % Cosim Options (HFSS)

28 2R FlanarEMSetup

i!"l Design Verification

@] Optimetrics EE]
----- Results
..... % Field Qverlays
..... Radiztion
-7 Definitions X

=3 Project15=
‘ EMDesign1™
[-/_7 Definitions

&

Properties

MName |‘-.-"a|ue| it |E".|'E

Setup Flan...
Enable [w
Saolver Flan...

Solution Fr... 5 GHz

Cut
Copy
Paste
Rename

Delete

Properties...
Disable Setup

Add Frequency Sweep...

Validate

Analyze
Submit Job...
Revert to Initial Mesh

Pre-Process Geometry
Invalidate Solutions
Export

Profile...
Convergence..,

Matrix Data...
View Mesh Feedback...

Metwork Data Explorer

Ctrl+ X
Ctrl+C
Ctrl+V

F2
Delete

F10

2. Ensure Interpolating is selected from the Sweep Type drop-down menu.
3. Select Linear Count from the Distribution drop-down menu in the first row of the

Frequency Sweeps table.
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Edit Frequency Sweep *

Edit Frequency Sweep ] Interpolation |

Sweep Mame: |Sweep1 [+ Enabled

Sweep Type: | Interpalating ﬂ

Freguency Sweeps [401 points defined]

Linear Step

Linear Count

Log Scale

Add Above Add Below Preview ... |

Time Domain Calculation... |

QK | Cancel

4. Enter the following parameters in the first row of the Frequency Sweeps table:
* Enter 1.5 (GHz) in the Start column.
* Enter 4.5 (GHz) in the Stop column.
e Enter 201 in the Points field.

Note:

For interpolating sweeps, generating surface current data is only good for the last
adaptive pass of the solution frequency. Surface current data cannot be saved for fixed
mesh analyses.
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Edit Frequency Sweep

Edit Frequency Sweep ] Interpolation |

Sweep Mame: |Sweep1 [+ Enabled
Sweep Type: |Ir|ter|:u:|lating j
Freguency Sweeps [201 points defined]
Distribution | stat |  End
1 |Linear Count 1,5GHz 4.5GHz Paints 201

Prewiew ... |

Time Domain Calculation...

QK | Cancel
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Note:

From the Edit Frequency Sweep window, click Preview to display the Sweep Points
window.

B 201 Sweep Points >
Index Point Range[s] s
1 1.5000 EH=z [1]
2 1.5150 GH=z [1]
3 1.5300 =H=z [1]
4 1.5450 H=z [1]
5 1.5€00 GH=z [1]
[ 1.5750 GH=z [1]
7 1.5%900 zH=z [1]
g 1.€050 EH=z [1]
5 1.€200 GH=z [1]
10 1.€350 GH=z [1] W
2.00
1.00
0.00
1.50 2.50 3.50 4.50
Points [GHz]

Click Close to return to the Edit Frequency Sweep window.

5. Click OK to add the interpolating sweep and close the Edit Frequency Sweep window.

Add a Discrete Frequency Sweep

1. From the Project Manager window, expand the Project Tree > [active design folder]
> Analysis folder. Then right-click the analysis setup (e.g., PlanarEMSetup1) and select
Add Frequency Sweep to open the Edit Frequency Sweep window.

Set Up Solution and Analyze 2-11
Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™ 3D Layout: Low Pass Filter

Edit Frequency Sweep

Edit Frequency Sweep | Intempolation |

v Enabled

Sweep Type: | Interpolating =l

—Freguency Sweeps [401 points defined]

Distribution Start End

Bl Linear Step Step si 0.05GHz

Add Above Add Below Delete Seleckion Preview ... |

Time Domain Calculation...

O ptiores

[T Generate suface curent

QK I Cancel

2. Select Discrete from the Sweep Type drop-down menu.
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Sweep Type:

Edit Frequency Sweep

Edit Frequency Sweep | Intempolation |

Sweep Mame: ISweepZ

v Enabled

Irtermpalating

=}

IrrteEnlatini
—Freguency S

Distribution

Bl Linear Step

Start End

0.05GHz

Add Above

Add Below Delete Seleckion Preview ... |

Time Domain Calculation... |

O ptiores

[T Generate suface curent

QK I Cancel

3. Select Linear Count from the Distribution drop-down menu in the first row of the

Frequency Sweeps table.
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Edit Frequency Sweep

Edit Frequency Sweep l

Sweep Mame: |5weep2 [+ Enabled

Sweep Type: | Diiscrete j

Freguency Sweeps [401 points defined]

Linear Step

Single Paint

Single Point Sweep

Linear Count
Prewiew ... |

Log Scale

Time Domain Calculation...

Ciptions

[ Generate suface cument

QK | Cancel

4. Enter the following parameters in the first row of the Frequency Sweeps table:
¢ Inthe Start column, enter 1.6 (GHz).
¢ Inthe Stop column, enter 2.6 (GHz).
e Enter 11 in the Points field.

Note:

For discrete sweeps, generating surface current data enables viewing of currents and
calculate far field effects at multiple frequencies in later post-precessing steps.

5. From the Options area, check the Generate surface current box.
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Edit Frequency Sweep *

Edit Frequency Sweep l

Sweep Mame: |5weep2 [+ Enabled

Sweep Type: | Diiscrete j

Freguency Sweeps [11 points defined]

Distribution | Start | End
1 |Linear Count 1.6GHz 2.6GHz Points 11

| | Prewiew ... |

Time Domain Calculation... |

Ciptions

v Generate suface cument

QK | Cancel

6. Click OK to finalize the discrete sweep and close the Edit Frequency Sweep window.

Continue to Explore Disabling Sweeps and Setups.

Deactivate/Activate Setups and Frequency Sweeps

Follow these instructions to activate or deactivate setup definitions and frequency sweeps.

Deactivate or Enable a Setup Definition

From the Project Manager window, expand the Project Tree > [active design folder]
> Analysis folder. Then right-click the setup (e.g., PlanarEmSetup1) and select Disable Setup
or Enable Setup. Only one option will be available, depending from the current status of the

Set Up Solution and Analyze 2-15
Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™ 3D Layout: Low Pass Filter

setup (e.g., if the setup is currently deactivated, only Enable Setup will appear in the shortcut

menu).

Project Manager

=3 GETSTART*
£ EMDesignl®

@ Circuit Elements
@ Boundaries
=53] Excitations

=56k Analysis

...... % Cosim Options (HFSS)

2 e PlanarEMSetupl

E". Design Verification Cut Ctrl+X
Optimetrics 23 Copy Ctrl+C
..... Results Pact Ctrl+V
..... M Field Overlays e -
..... Radiztion Rename F2
[ Definitions 3 Delete Delete
EI"E‘ Project15™
[)-él EMDesign1* Properties...
-2 Definitions Disable Setup
I_ Add Frequency Sweep...
Validate
% Analyze F10 r
Properties Submit loh... =
MName |"'-I"a|uE| Uit | Eval Revert to Initial Mesh [ ]
Setup Plan... Pre-Process Geometry #
Enable [vw
Solver Plan. Invalidate Solutions
Solution Fr.. 5 GHz Export d
@ Profile...
Convergence...
Matrix Data...
View Mesh Feedback...
Metwork Data Explorer
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Note:

Alternatively, deactivate/activate an analysis setup by either double-clicking the setup
(i.e., located at the Project Managerwindow > Project Tree > [active design folder]
> Analysis folder directory) or right-clicking the setup and selecting Properties to
open the PlanarEMSetup window. Beneath the Setup Name field, uncheck or check
the Enabled box and click OK to commit the change and close the window.

PlanarEMSetup1 X

General lOptiu:uns ] Advanced ] Advanced Meshing ] Snlver] Defaults ]

Setup Name: |PIanarE|"-"| Setup

[ Enabled
Mesh Selection
Fixed Mesh Standard Adaptive | Advanced Adaptive |

Solution Frequency: 5 |GH2 ﬂ

[ Use edge mesh
{+ 0.1

f_“ 1000.0000mm

Ise Defaults

HPC and Analysis Options...

oK | Cancel
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When an analysis setup is deactivated, any sweep associated with it has no effect, evenif an
associated sweep is enabled.

Deactivate or Activate a Sweep Definition

From the Project Manager window, expand the Project Tree > [active design folder]

> Analysis folder > setup (e.g., PlanarEMSetup1). Then right-click the sweep (e.g., Sweep1)
and select Disable Sweep Analysis or Enable Sweep Analysis. Only one option will be
available, depending from the current status of the setup (e.g., if the sweep is currently
deactivated, only Enable Sweep Analysis will appear in the shortcut menu).

Project Manager o =

=] GETSTART*

54 EMDesign1*
@ Circuit Elements
@ Boundaries
=-[E] Excitations

=5k Analysis

...... %5 Cosim Options (HF5S)

EZH PlanarEMSetup1

|_ Sweep2 Cut Ctrl+X
E". Design Verificatior 23 Copy Cirl+C
@ Optimetrics
..... Results Rename F2
----- % Field Overlays . Delete Delete
----- Radiation _
-7 Definitions Properties...
=13 Project15= Analyze
-4l EMDesigni* Disable Sweep Analysis

-3 Definitions Invalidate Solution

Results
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Note: Alternatively, deactivate/activate a sweep analysis by either double-clicking the
sweep (i.e., located at the Project Managerwindow > Project Tree > [active design
folder] > Analysis folder > setup (e.g., PlanarEMSetup1) directory) or right-clicking
the sweep and select Properties to open the Edit Frequency Sweep window.
Uncheck or check the Enabled box and click OK to commit the change and close the
window.

Edit Frequency Sweep *

Edit Frequency Sweep ] Interpolation |

Sweep Name: |5weep1 [ Enabled

Sweep Type: | intemolating -

Freguency Sweeps [201 points defined]

Distribution Start End

(M | inear Count

Add Above Add Below Preview ... |

Time Domain Calculation... |

QK | Cancel

Continue to View the Mesh.

View the Mesh

Follow these instructions to view the active design in a number of planar or 3D views.
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Note:

If the Layout Editor is closed or another window is dominant, navigate to HFSS
3D Layout and select Layout Editor.

B File Edit View Project Draw Layout  HF553D Layout Tools Window Help

| I . Cut  ¥) Undo [ = EMDesign? Design Settings...
] S Oar - .
=i adg s i =t Add Subcircuit >
Save i ~ -
Paste Delete | Jeg ™ o
F‘H Port Excitations...
Desktop View Layout Simulation Differential Pairs
Project Manager Reorder Matrix...
El@ GETSTART* Solution Setup E
O-és EMDesignl*
.[3] Circuit Elements Optimetrics Analysis »
[EP] Boundaries E HFSS Extents...
=-{E3] Excitations BR List.
. 1 o
g Dl Qé?.a Validation Check...
. p
B3 Analysis @n Geometry Check...
..... % Cosim Options (HFSS) :I Edit Motes...
EZH PlanarEMsetup1 & Analyze F10
..... |_ S'J"-'EEI:I]. I'% TL”_IEIII
ib. . Sweenz - .
[:.. Sweep Submit Job...
m-i' Design Verification
l@ Optimetrics Results ¥
----- Results _
----- % Field Overlays Hﬁﬁ Layout Editor
..... Radiation Schematic ¥
-1 Definitions [] Estimate..
E”m Project15™ = CloseEditors
-4 EMDesign1*
-2 Definitions Convert Geometry to Vias...

Select In Layout

Set Termperature
Properties

Design Properties...

MName |‘u’alue| LIt |E~.-'aluateu:| Walue

Design Passed Parameters...

5 Swe...
. e Design Datasets...
Enable [
Start 15  |GHz Toolkit >
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If the Layout Editor is still open but no longer dominant, navigate to Window and

select the active design project from the available options.

Window Help
MNew Window
Cascade Ctrl+0
Tile Horizentally Ctrl+1
Tile Vertically Ctrl+2

Arrange lcons

Close All

~ 1 GETSTART - EMDesign? - Layout
2 Project15 - EMDesignl - Layout

From the Project Manager window, expand the Project Tree > [active design folder]
> Analysis folder. Then right-click the setup (e.g., PlanarEmSetup1) and select Pre-Process
Geometry > Display.
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Project Manager

=] GETSTART*

5-é EMDesign1*
@ Circuit Elements
@ Boundaries
[_]@ Excitations

=988 Analysis

EIZH PlanarEMsetup

| Sweepil

MName |"u"a|ue| it |E'u'

Setup Flan...
Enable [v
Solver Flan...

Solstion Fr... 5 GHz

------ ﬁ?‘.‘; Cosim Options (HFSS)

Cut

tofi Sweep2 | 53 Copy

I-PI Design Verification Pacte
@ Optimetrics
..... Results Rename
----- ﬁ Field Overlays . Delete
----- ¥ Radiation _
[#-[Z0 Definitions SRR
=-EF Project15* Dizable Setup
‘ EMDesign1® [-: Add Frequency Sweep...
-7 Definitions Validate
& Analyze
Properties Submit Job...

Revert to Initial Mesh
Pre-Process Geometry
Inwvalidate Solutions

Export

0 Profile..

Convergence...

Matrix Data...
View Mesh Feedback...

Metwork Data Explorer

Ctrl+x
Ctrl+C
Ctrl+V

F2
Delete

F10

b

Display
Refresh
Dynamic Updates

Floating/lnactive Geometry
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Note:

Alternatively, left-click the setup (e.g., PlanarEmSetup1) and navigate to HFSS
3D Layout > Solution Setup > Pre-Process Geometry > Display.

FHEin E& E®

HFS5 30 Layout = Tools

Design Settings...
Add Subcircuit

Port Excitations...
Differential Pairs
Reorder Matrix...
Solution Setup

Optimetrics Analysis
HFS5 Extenis...

List...

Validation Check...
Geometry Check...
Edit Motes...
Analyze

Tune...

Submit Job...

Results

Layout Editor
Schematic
Estimate...

Close Editors

Convert Geometry to Vias...

Select In Layout
Set Temperature

Design Properties...

Design Passed Parameters...

Design Datasets...

Toolkit

Window Help

F10

Fit All

F

i - T
'-
H

ORI
7 JdJ

e
[+

@ el 7
N
PRCRT

[P Unite ﬁ;ﬂ
L K subtract W5
[ Intersect

B

B e & B

Add HFS5 Solution Setup...

Add Planar EM Solution Setup...
Add Slwave Solution Setup ...

Add Slwave DCIR Solution Setup ...
Add EMI Scanner Setup ...

Add Mexxim Selution Setup...

Add Nexxim Solution Options ...
Add Frequency Sweep...

Pre-Process Geometry

Co-Simulation Options...

- Display
Refresh
Dynamic Updates
Alternative Mesh Overlay

Fleating/lnactive Geometry

pl

A 3D mesh appears on the model in the Layout Editor.
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p p2

The mesh does not display on a layer that is not visible, and if there are self-intersecting mesh
edges, they will appear highlighted in yellow.

Note:

If this topic has been reached in succession after completing the steps in Explore
Disabling Sweeps and Setups, leave the mesh visible on the model. However, the
mesh can be deactivated by repeating either method described in this topic to view the
mesh. A check mark appears adjacent to Display when the mesh is visible and
disappears when the mesh is hidden.

~  Display
Refresh
Dynamic Updates
Alternative Mesh Overlay

Fleating/Inactive Geornetry

Continue to Explore Dynamic Mesh Updates.

Choose Manual or Dynamic Mesh Updates

Objects in the Layout Editor can be stretched, compressed, skewed, and otherwise
manipulated by click+dragging the handles that surround the objects, at the edges and
midpoints. By default, an object's mesh is not dynamically updated when the geometry of an
objectis altered. The following instructions explain how to refresh the mesh manually or enable
Dynamic Mesh to update the mesh in real time.
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Update the Mesh Manually

From the Project Manager window, expand the Project Tree > [active design folder] >
Analysis folder. Then right-click the setup (e.g., PlanarEmSetup1) and select Pre-
Process Geometry > Refresh.
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Project

Manager

=-F: GETSTART*
-8 EMDesignl®

@ Circuit Elements
@ Boundaries
=-{EJ] Exditations

=98 Analysis

ffs Sweep2
r’l Design Verification
@ Optimetrics
----- Results
----- ﬁ Field Overlays
----- Radiation

-2 Definitions

= Project15=
- EMDesign1*
I:l Definitions

Properties

r}.‘a Cosim Qptions (HFS5)

MName |"u"a|ue| Uit |E1.ra|

Setup Flan...
Enable [v
Solver Flan...

Solution Fr...|5 GHz

Cut
Copy
Paste

Rename

Delete

Properties...

Disable Setup

Add Frequency Sweep...

Validate

Analyze
Submit lob...
Revert to Initial Mesh

Pre-Process Geometry
Invalidate Solutions
Export

Profile...
Convergence...

Matri Data...
View Mesh Feedback...

Metwork Data Explorer

Ctrl+X
Chrl+C
Ctrl+V

F2
Delete

F10

~  Display
Refresh
Dynamic Updates

Floating/Inactive Geometry
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Note:

Alternatively, left-click the setup (e.g., PlanarEmSetup1) and navigate to HFSS
3D Layout > Solution Setup > Pre-Process Geometry > Refresh.

B File Edit View Project Draw Layout HFS53D Layout Tools Window Help
I 4 Undo  [M] ~ EMDesign1 Design Settings... Fit All H-T PSS |L|® &% @Dui [
[ N
e g /= Add Subcircuit > F Q- ma A R|SNO 1 [ subtract Y
w T R 28 = Intersect ol
= FH Port Excitations... EH* O 8 « ®
Desktop View Layout Simulation Differential Pairs
Project Manager Reorder Matrix...
=@ G‘FTFTART* ey Sam > Add HFSS Solution Setup.. >
-é® EMDesignl* .
) Crcuit lements T , BB Add Planar EM Solution Setup...
3 _ Boundaries @ HFSS Extents... kx| Add Slwave Solution Setup ...
EI@ Excitations B L. E Add Slwave DCIR Solution Setup ...
..... 1
g D2 &% Validation Check... [ Add EMI Scanner Setup
..... p 5 |
e A s
----- B Cosim Options (HFSS) B  Edit Notes... sadm seiution Uptions ...
57 PlanarEMsetup1 ﬁ Analyze F10 I_ Add Frequency Sweep...
ll: Sweepl % Tune. Pre-Process Geometry » v Display
ol Sweep2 X
...g# Design Verification Submit Job.. Co-Simulation Options... REﬁeSh.
-{F) optmerics Results > T ' ' Dynamic Updates
-.[FH] Resuits ) Alternative Mesh Overlay
Mgy Field Overlays f#i  Layout Editor : o
.5 Radiation Schematic y | Floating/Inactive Geometry
-3 Definitions E  Estimate..
=B Project 5~ o Close Editors
[ EMDesign1®
&]-[L7 Definitions Convert Geametry to Vias... h
Select In Layout |
Pl ‘
Set Temperature
Properties
Design Properties...
Name |‘u"a|ue| Uit | Evaluated Value T e e s
Set Plan...
P =n Design Datasets...
Enable [v
Salver Plan... Toolkit >
Important:

The consolidation of surfaces into a conformal mesh is skipped for dynamic and
tolerant meshing, including those with light weight geometries. This can lead to
overlapping surfaces in SBR+ simulations. The user should carefully avoid overlapping
surfaces or objects as SBR+ can produce unexpected results.

Enable Dynamic Updates

From the Project Manager window, expand the Project Tree > [active design folder] >
Analysis folder. Then right-click the setup (e.g., PlanarEMSetup1) and select Pre-
Process Geometry > Dynamic Updates.
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Project Manager R ox
=] GETSTART*
-8 EMDesignl*
@ Circuit Elements
@ Boundaries
(- {B3] Excitations
-9 Analysis
.8, Cosim Options (HFSS)
N afrlanarEMSetupl
ril Design Verification Cut Ctrl+x
Opﬁl’l’lEtl'iES __:Eﬁl CI:IFl}" Ctrl+C
----- Results . —_
----- ﬁ Field Overlays e o
""" Radiation Rename F2
- (] Definitions # Delete Delete
Properties...
Disable Setup
I_ Add Frequency Sweep...
Validate
& Analyze F10
Submit Job... P
Properties Revert to Initial Mesh oy
MName |"u"a|ue | Unit | Eva Pre-Process Geometry ’ Display
Setup Plan... Invalidate Solutions 2=
Enable [v Dynamic Updates
Solver Plan... Export > o .
Floating/Inactive Geormnetry
Solution Fr...|5 GHz @ Profile...
Convergence..,
Matrix Data...
View Mesh Feedback...
Metwork Data Explorer
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Note:

Alternatively, left-click the setup (e.g., PlanarEmSetup1) and navigate to HFSS
3D Layout > Solution Setup > Pre-Process Geometry > Dynamic Updates.

a

i L

s

Fit All

BT @)% Bume Ba
5 F Q- 1 K subtac W3
ﬁ #

[@ Intersect 25

one
7 dJ
@5 9
P @@

B

¥ Add HFS5 Solution Setup... ]
5 BB Add Planar EM Solution Setup...

Add Slwave Solution Setup ...

Add Slwave DCIR Solution Setup ...

Add EMI Scanner Setup ...

Add MNexxim Selution Setup... ¥
Add MNexxim Selution Options ...

S

F10 |_ Add Frequency Sweep...
Pre-Process Geometry ¥ Display

Co-Simulation Options... Refresh
* I ' Dynamic Updates

Alternative Mesh Overlay

3 Floating/Inactive Geometry

pl

B File Edit View Project Draw Layout HFS53D Layout Tocls Window Help
I € Undo | [%] ~ EMDesign1 Design Settings...
]
g = Add Subcircuit
Save k
B4 Port Excitations...
Desktop View Layout Simulation Differential Pairs
Project Manager Reorder Matrix...
=] @ GETSTART* Solution Setup
£-é@ EMDesign1*
@ Circuit Elements Optimetrics Analysis
[BP) Boundaries B HFSS Extents...
[]--@ Exditations g List...
=98 Analysis
; Validation Check...
H (5?.3 Cosim Options (HFS5) QZ alidation Lhec
(1A PlanarEMsetup1 @ Geometry Check...
ﬂ"l Design Verification ] Edit Motes...
l@ Optimetrics % Analyze
..[F¥] Results i b T
% Flelc.l gverlays Subrmit Job..
.5 Radiation
-] Definitions Results
& Layout Editor
Schematic
E Estimate...
g CloseEditors
Convert Geometry to Vias
Select In Layout
T Set Temperature
Name |Va|ue| Unit | Evaluated Value P s
Setup Plan._. Design Passed Parameters...
Enable [w Design Datasets...
Solver Plan... Toolkit

Reset the Mesh After Using Undo or Redo

Even if Dynamic Updates is enabled, using the Undo or Redo commands to reset the
geometry of the design will disrupt the dynamic update process and the mesh will not
immediately conform to the reset geometry. Refresh, as previously described, to reset the

mesh.

Deactivate Dynamic Updates

Deactivate dynamic updates by repeating either method described in this topic to enable
dynamic updates. A check mark appears adjacent to Dynamic Updates when dynamic updates
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are enabled and disappears when dynamic updates is deactivated.

~  Display
Refresh
~  Dynamic Updates

Floating/Inactive Geornetry

Important:
Before continuing, Save the design.
Experiment with the Layout Editor by activating the mesh, enabling dynamic updates, and

then distorting or even adding new geometry to the model. Use the Select (O) and Handles
(H) modes to update the cursor, then click+drag to alter the model, as chosen.

After experimenting, deactivate the mesh.

Continue to Run the Analysis.

Run Analyses and Choose Analyses Options

To sequentially run all analysis setups and associated frequency sweeps in the active design, do
one of the following:

* From the Simulation tab, select Analyze.

/ EEE Active: Local -
@ E EEAnalysiannfig
Validate Analyze HPC
Options

{.} Analyze
@ Analyze current HFSS 30 Layout

Circuit,
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* From HFSS 3D Layout, select Analyze.

o i i B & [l o

HFS5 30 Layout | Tools

Design Settings...
Add Subcircuit

Port Excitations...
Differential Pairs
Reorder Matrix...

Solution Setup

Optimetrics Analysis
HF55 Extents...

List...

Validation Check...
Geometry Check...
Edit Motes...
Analyze

Tune...

Submit Job..,

Results

Layout Editor
Schematic
Estimate...

Close Editors

Convert Geometry to Vias...

Select In Layout
Set Ternperature

Design Properties...

Design Passed Parameters...

Design Datasets...

Toolkit

Window Help

F10

» From the Project Manager window, expand the Project Tree > [active design folder].
Then right-click Analysis and select Analyze.
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Project Manager o =
=3 GETSTART*
5-é EMDesignl*
@ Circuit Elements
@ Boundaries
Eﬂ--@ Excitations

=
.. B, Cosil Paste Ctrl+V
-] Plan;
m"l A i Add HFS5 Solution Setup .. »
Design ¥

@ Optimetr Add HFSS Custom Setup ...
----- Results: B Add Planar EM Sclution Setup ...
""" Field Ovi 7] Add Slwave Selution Setup ...
Eﬂudzﬁ:;dui::':' [# Add Siwave DCIR Solution Setup ...
Add EMI Scanner Setup ...
Add Mexxim Sclution Setup... b

Add Mexxim Sclution Options ...

&% Analyze F10
Generate Mesh

Invalidate Solutions

- Browse Solutions...
pet R -
) #| Clean Up Solutions...
Properties =
4/  Import Solution...

Update Menu
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Note:

Alternatively, run a single sweep by expanding the Project Tree > [active design
folder] > Analysis folder in the Project Manager window. Then right-click the chosen
sweep and select Analyze.

m Ansys Electronics Desktop 2022 R1 - GETSTART - EMDesign1 - Layout - [GETSTART -
B File Edit View Project Draw Layout HFS5 30 Layout Tools  Window

H; :ﬁM£EﬁD

Save HF55 Slwave DCIR EMI PlanarEM Sweep O
Desktop View Layout Simulation Results Automation An
Project Manager o =

=3 GETSTART*

548 EMDesign1*
@ Circuit Elements
@ Boundaries
+-{F3] Excitations
-8 Analysis

...... % Cosim Options (HFSS)

EZH PlanarEMSetupl

..... IH Sweepl

I'_ Sweep2 Cut Ctrl+X
m-il Design Verificatic 2y Copy CirleC
@ Optimetrics
..... Results Renarne F2
----- % Field Overlays 2% Delete Delete
----- Radiztion .

-2 Definitions Properties...
Analyze

Disable Sweep Analysis
Invalidate Solution

Results >

View Progress

From the Electronics Desktop status bar, select Show Progress to expand the Progress
window.
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= Show Progress

During analysis, perform the following actions, as appropriate:

+ Right-click within the Progress window and select Abort, Clean Stop, or Pause. Clean
Stop completes the computation of the current frequency point, then analysis ends.

Pragress 1 x
EMDesign1 on Local Machine - RUNNING |
j]
Abort
Clean Stop
Change Priority >
Pause
Resume
» Right-click within the Progress window and select Change Priority > (Highest, Above
Normal, Normal, Below Normal, or Lowest Priority), to change the priority of the
associated solution. Altering the priority can be useful when multitasking, to free up
resources from a computationally intensive application. Conversely, it can prevent less
important programs from excessively slowing down the more intensive application.
Progress 2 xl
EMDesign1 on Local Machine - PAUSED ot
Clean Stop \r j‘|
Change Prierity > Highest |

Pause Above Mormal
Resume ~  Nermal

Below Normal

Lowest Priority

Animated Demonstration

Continue to View S Matrix Data.
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3 - Evaluate the Results (Post-processing)

Use the post-processing capabilities of Ansys Electronics Desktop to display the results of a
simulation. Also use the export features to save the analysis data (and an equivalent circuit) in
various industry-standard file formats.

The sections in this topic include:

View S Matrix Data

Plot Return Loss

Plot a User-Defined Graph

Revise p2 Excitation

Overlay Current Results

Modify and Animate Current Overlay
Create Far Field Plot

Overlay Far Field Plot on Model Geometry
Frequency Animated Far Field Plot

View S Matrix Data

Follow these instructions to review the scatter matrix (S Matrix) data at all sweep frequencies or
at a selected frequency, as well as Y and Z matrix data.

1.

From the Project Manager window, expand the Project Tree > [active design folder] >
Analysis folder > setup (e.g., PlanarEMSetup1). Then right-click the chosen sweep (e.g.,
Sweep1), and select Results > Matrix Data to open the Solutions window.
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Project Manager

=3 GETSTART*

5-é EMDesignl*
@ Circuit Elements
@ Boundaries
Eﬂ--@ Excitations
=988 Analysis

...... % Cosim Options (HFSS)

EZH PlanarEMSetupl

- e B

il

ofr Sweep2 Cut

I-il Design Verificatic 33 Copy

{8 Optimetrics -

..... Results Rename

..... % Field Overlays v pelete

..... Radiation

-ZJ Definitions Properties...

Analyze

Disable Sweep Analysis

Invalidate Solution

Ctrl+X
Ctrl+C

F2
Delete

Properties Results > [S] Matrix Data
Name Value | Unit | Evahigted Metwork Data Explorer
Sweep Sweep1 Plot Templates

2. From the Matrix Data tab, ensure the S Matrix box is checked.
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Profile ] Convergence  Matrix Data l Mesh Statistics ]

|'I.EGH2 ﬂ [ Display All Frequencies Edit Frequencies ...

[v 5 Matrix [ Y Matrix [ Z Matrix [ Gamma [ Zo

View | Format ] Passivity ] Export ]

B " Solutions: GETSTART - EMDesign - O b
Simulation: |PIanarEM5ﬂtup1 j |5WEE|]1 j
Design |

Freq | S:p1 | 5:p2 |
p1[0.98999, -1.13)[0. 0]

B ez(o, 0 (0.98999, -1.13]
]

Close

3. Check the Display All Frequencies box.
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B Solutions: GETSTART - EMDesign - O
Simulation: |PIanarEM5ﬂtup1 j |5WEE|]1
Design |

Profile ] Convergence  Matrix Data l Mesh Statistics ]

v Display All Frequencies Edit Frequencies ...
v S Matrix [ Y Matrix [ Z Matrix [ Gamma [ Zo

View | Format ] Passivity ] Export ]

Freq | spl | 3:p2 |

g

pl [0.98999, -1.13)(0, 0
p2 (0.  0) (0.98999, -1.13)

AP p1 (0.98979, -1.14)(0, 0)
p2(0, 0 [0.98979, -1.14)

RS p1 [0.98959, -1.15) (0, 0
p2(0, 0] (0.98959, -1.15)

Close

4. Navigate to the Format sub tab. Then choose the chosen data format from the drop-down

menu (i.e., Magnitude/Phase(deg), dB/Phase(deg), Real, Imaginary, Magnitude,
Phase(deg), or dB).
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B Solutions: GETSTART - EMDesign - O
Simulation: |PIanarEM5ﬂtup1 j |5WEE|]1
Design |

Profile ] Convergence  Matrix Data l Mesh Statistics ]

Defmit (= Custom : j 5 j r

Magnitude/Phaseldeq) ﬂ

Magnitude/Phase{deq)
= Real /Imaginany
dB/Phaseldeg)
Real
Imaginary
Fyf Magnitude | S:p2 |

Vi

Phaseldea)
Jj[o, 0)

p2 (0, 0] (0.98999, -1.13)

AP p1 (0.98979, -1.14)(0, 0)
B pz(n. (0.98979, -1.14)

JEEETEN p1 (0.98959, -1.15)(0, 0]
B pzo, g (0.98959, -1.15)

Close

5. To see runtime data pertaining to the analysis, navigate to the Profile tab.
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B Solutions: GETSTART - EMDesign - O
Simulation: |PIanarEM5ﬂtup1 j
Design |

Profile | Canvergence | Matrix Data | Mesh Statistics |

Task Real Ti... |CPU Time| Memory
Start Time: 11032021 12:53:38; Host: AAPUY.
Executing from C:A\Program Files\AnsysEl
HPC Enabled
Solution - Swe... Discrete PlanarEM Frequency Sweep

From 1.6GHz to 2.6GHz, 11 Frequencies

Frequency - 1.... PlanarEM
Advanced Setti... Accuracy level 2; Direct Solver; Number
Simulation setup 00:00:00 00:00:00 2210 M 148 Unknowns; 122 Triangles.

Matrix Assembly 00:00:00 00:00:01 A1 M

I atriv Snhea nn-nn-nn_nn-nn-nn._ A1 4 WJd
L4 >

Export...

Close

6. To export data, do the following:

a. Navigate to the Export sub tab and click Export Matrix Data to open an explorer
window.
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B " Solutions: GETSTART - EMDesign

Simulation: ‘F‘IanarEMSetum j |Swat:p1

Design ‘

Prafile ] Convergence  Matrix Data l Mesh Statistics

| Export Matrix Data... | Equivalent Circuit Export... |

View ] Furrnat] Passivity Export

Freq | s5:p1 | S:p? |

o

pl(0.98999, -1.13](0, 0]
p2 (0, 0 (0.98999, -1.13)

WAL F p1 (098979, -1.14)(0, 0)
p2 (0, 0 (0.98979, -1.14)

WLETEEN p1 (098959, -1.15)(0,  0)
p2(0, 0 (0.98959, -1.15)

Close
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m Export Network Data Solution

€« v » ThisPC » OS5(C) » ansysdev » ExampleFolder v ] Search ExampleFolder

Organize v Mew folder H==

@ OneDrive - ANSYS Mame Date modified Type Size

= This PC Mo items match your search.

M 3D Objects
[ Desktop
= Documents
4 Downloads
J’S Music
=] Pictures
m Videos
5 [
= DocTools (NWCHC

£ Network W

File name: | ExampleFile

Save as type: | Touchstone (*.sMNp)

A Hide Folders Cancel

b. From the explorer window, do the following:

i. Type aFile name, or use the default (e.g., <ProjectName_DesignName>).

ii. Choose the chosen file format from the Save as type drop-down menu (e.g.,
Touchstone (*.sNp), Data Table (spreadsheet) (*.tab), Neutral Model Format
(*.nmf), MATLAB (*.m), or Citifile (*.cit)).

iii. Navigate to the chosen save location. (Default save location is the folder where the
model is saved).

iv. Click Save to save changes, close the explorer window, and return to the Solution
window, or click Cancel to close the explorer window without exporting anything.
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7. To export the matrix data as an equivalent SPICE model, do the following:
a. From the Export sub tab, click Equivalent Circuit Export.

Note: SPICE models require solution data at DC (OHz) conditions. If there is
no DC frequency value available, a warning dialog box will appear.

Ansys Electronics Desktop
f - Mo DC frequency value is available,
‘¥ Do youwish to continue?

Yes Mo

b. Click Yes to close the dialog box and open the Equivalent Circuit Export Options
window.
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Equivalent Circuit Export Options

Default Directory: C:JUsersfacharpen/OneDrive - ANSYS, Inc/Desktop

Format:  |PSpice [*.lib]

Full Wave Spice
v Full Wave Spice Export

Desired Fitting Error [Percent]

Maximum Order
v Uge Common Ground

[ Enforce Passivity

[~ Lumped Element Export [Low Bandwidth)

[ Partial Fraction Expansion for Matlab [*.m)

W-element Export

r

0K

|GETSTAF{T_h-;s.IiIJ

|n.5

|1ﬂﬂﬂﬂ

|GETSTAHT_IM5.Iih

|GETSTAHT_pie.m

|GETSTAHT.5|J

Cancel ‘

c. Selectthe chosen save location, file format, and other equivalent circuit options.
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d. Click OK to save changes, close the Equivalent Circuit Export Options window, and
return to the Solution window, or click Cancel to close the window without exporting

anything.
8. Close the Solutions window.

Continue to Plot Return Loss.

Plot Return Loss (a Standard Report)

Complete these steps to create a report and plot return loss.
1. Open the Report window by doing one of the following:
* From the Results tab, select Standard Report > 2D.
('( E i Browse Solutions
L i Nﬁ | Clean Up Solutions

Solution Metwork
- Data Data Explorer .Impnrt Solutions

pi Y .
A mmnmu @ &
f II|ul |\__ ¥

ANANARAAAAT EEE
Stacked Palar Data Table
Y
S —.: iy v
[ & '...'
Smith Chart 30 Rectangul... 30 Polar

%Q,,

3D Spherical 20 Contour Smith Contour
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* From HFSS 3D Layout, select Results > Create Standard Report > Rectangular Plot.

Design Settings...
Add Subcircurt

F‘H Port Excitations...
Differential Pairs
Reorder Matrix...
Solution Setup

Optimetrics Analysis
HFS5 Extents...

List...

Validation Check...
Geometry Check...
Edit Motes...
Analyze

SETE&

Tune...
Submit Job...

Results

8 Layout Editor
Schematic

H Estimate...

B’ Close Editors

Convert Geometry to Vias...

Select In Layout
Set Temperature

Design Properties..,
Design Passed Parameters...

Design Datasets..,

Toolkit

HF55 30 Layout  Teols  Window  Help

F10

S Browse Solutions

" twj . Clean Up Solutions
etwaor
Data Explorer Import Solutions

5

Accumulate Reports

Import Selution..

Browse Solutions...

Optimetrics Results...

@

Profile...

Matrix Data

=

Plot Templates
Create Standard Report
Create Report From File...

[ Delete All Reports
Report Templates

User Defined Solutions...
Create User Defined Solution

Dataset Solutions...

Cutput Variables..,
Update All Reports
Open All Reports

Create Document

Perform FFT on Report ...
Perform TDR on Report ...

Rectangular Plot
Rectangular Stacked Plot
Polar Plot

Data Table

Smith Chart

3D Rectangular Plot

3D Rectangular Bar Plot
3D Polar Plot

3D Spherical Plot
Rectangular Contour Plot

Smith Contour Plot
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¢ From the Project Manager window, expand the Project Tree and [active design
folder]. Then right-click Results and select Create Standard Report > Rectangular

Plot.
Project Manager o=
=3 GETSTART*
£-&8 EMDesignl®
.[3F] Circuit Elements
@ Boundaries
+-{F3] Excitations
-8 Analysis
., Cosim Options (HFSS)
=] PlanarEMsetup1
----- IH Sweepl
I'._. Sweepl
..o Design verification
@ Optimetrics
----- |
..... Ty Field O, [ Paste Ctrl+V
""" Radiatic Create Standard Report > Rectangular Plot
-7 Definitions .
Create Report From File... Rectangular Stacked Plot
[ Delete All Reports Polar Plot
Data Table
]
Report Templates Smith Chart
User Defined Solutions... 3D Rectangular Plot
———————— Create User Defined Sclution * 3D Rectangular Bar Plot
Properties
Dataset Solutions... elEE
30 Spherical Plot
Output Variables...
Hrput Tanahies Rectangular Contour Plot
Update All Reports Smith Contour Plot
Open All Reports
Create Document »

Perform FFT on Report ...
Perform TOR on Report ...

2. The Report window opens from the Trace tab.
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Context

Solution:

@ Report: GETSTART - EMDesign - 5 Parameter Plot 1 - dB{5(p1,p17)

Trace I Families ] Families Display ]

|F‘|anarEI‘~"ISE1J_|p1 : Sweepj T — |Freq

Domain:

|

]

|Sweep j :

v Default | Freq

=

v:  |dBEELPL)

Category:

Variables

Y Parameter
Z Parameter
Group Delay
Return Loss
VSR
Gamma
Port Zo
Passivity

IUpdate Report

[v Real time

OuEut Variables

Quantity: il
s(p2,p1)
slp1,pd)
s(p2,p2)

Range
Function...
Function:

<nong > A
ang_deg
ang_deg_val
ang_rad

arg

cang_deg
cang_deq_val
cang_rad

dB 10normalize
dB20normalize
dBic

dBm

dBu v

Mew Report

Qutput Variables. .. | Dpﬁnns...|

Apply Trace | AddTrau:E|

Close

Note:

The settings described in Step 3 are the default settings in the Report window and it

should not be appropriate to change anything.

3. From the Trace tab, select the following:

a. Choose a sweep from the Solution drop-down menu (e.g., PlanarEMSetup1 :

Sweep1).
b. From the Category list, select S Parameter.
c. From the Quantity list, select S(p1,p1).
d. From the Function list, select dB.

4. Click New Report and the return loss plot opens under the Report window.

5. Close the Report window to view the plot.
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S Parameter Plot 1

EMDesign1 Ansys

250 -

-5.00 -

750

-10.00 —f

-12.50 +

dB(S(p1,p1))

-15.00 7

-1750 o

-20.00 —f

-22.50

Curve Info

— dB(S(p1,p1))

PlanarEMSetup1 : Sweep1

-25.00 T T T T T T T T T T T T T T T T T T
150 2.00 250 3.00 350 4.00

Freq [GHz]

4.50

Note:

Return to the plot any time from the Project Manager window (i.e., expand the Project
Tree > [active design folder] > Results folder, and double-click the chosen plot).

=-F'] GETSTART*
54 EMDesign1®
@ Circuit Elements
@ Boundaries
- [FA] Excitations
488 Analysis
E"I Design Verification
{8 Optimetrics
=--F% Results
-5
L. dB(S(p1,p1))
..... % Field Qverlays
..... Radiation
-1 Definitions

+1....I%1
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Note:

For additional details about formatting the plot, refer to Post Processing and
Generating Reports.

Continue to Plot a Smith Chart.

Plot a Smith Chart

A Smith chart is a convenient means of simultaneously displaying multiple parameters (e.g.,
impedance, reflection coefficients, scattering parameters, constant gain contours, et cetera). Itis
a useful graphical aid for electronics engineers working in the radio frequency disciplines.
Complete these steps to create a smith chart.

1. Open the Report window by doing one of the following:
* From the Results tab, select Standard Report > Smith Chart.

('(‘ E i Browse Solutions
1 ﬂ Nﬁ Clean Up Solutions

Solution Metwork
- Data Data Explorer .Impnrt Solutions

7Y T
Patl mmmuu @
PV W i

MBI e
20 Stacked Palar Data Table
Cy =) | " oy
= m.,..f .
smith Chart Sl'lllth Chart 3D Rectangul... 3D Palar

O = ©

3D Spherical 20 Contour Smith Contour
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* From HFSS 3D Layout, select Results > Create Standard Report > Smith Chart.

& 08 i B & [l

HFS5 30 Layout  Tools

Design Settings...
Add Subcircuit

Port Excitations...
Differential Pairs
Reorder Matrix...

Solution Setup

Optimetrics Analysis
HF55 Extents...

List...

Validation Check...
Geometry Check...
Edit Motes...
Analyze

Tune...

Submit Job...

Results

Layout Editor
Schematic

Estimate...

Close Editors

Convert Geometry to Vias...

Select In Layout
Set Temperature

Design Properties..,
Design Passed Parameters...

Design Datasets..

Toolkit

Window Help

F10

T

-20.00

-22 &l

T Browse Solutions

- tw: . Clean Up Solutions
etworl
ata Explorer Import Solutions

¥  Accumulate Reports

4 Import Solution...
5 Browse Solutions...

Optimetrics Results...

Profile...
[S] Matrix Data

Plot Ternplates ¥

Create Standard Report » Rectangular Plot

Create Report From File... Rectangular Stacked Plot

[ Delete All Reports izl

Data Table

Report Termplates ¥ Srmith Chart

User Defined Solutions... 3D Rectangular Plot

Create User Defined Selution > 30 Rectangular Bar Plot
30 Polar Plot

Dataszet Solutions...
3D Spherical Plot

Output Variables...
P Rectangular Contour Plot

Update All Reports
Open All Reports

Smith Contour Plot

Create Document »

Perform FFT on Report ...
Perform TDR. on Report ...
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¢ From the Project Manager window, expand the Project Tree and [active design
folder]. Then right-click Results and select Create Standard Report > Smith Chart.

Project Manager

=3 GETSTART*
—-é# EMDesignl*

-[EP] Boundaries
]@ Excitations
988 Analysis

+1-...I51

l@ Optimetrics

.5
Q SP 3

----- Field On,

----- Radiatic

-ZJ Definitions

m

S

prn
Properties

@ Circuit Elements

E"I Design Verification

Paste

Create Standard Report
Create Report From File...

Delete All Reports
Report Templates

Uzer Defined Solutions...
Create User Defined Solution

Dataszet Solutions...
Output Variables...

Update All Reports

Open All Reports §
-15.00 —
Create Document 4
Perform FFT on Report ... -
Perform TDR on Report ... ]
17 50 —

Ctrl+V

o x

-5.00 T

Rectangular Plot
Rectangular Stacked Plot
Polar Plot

Data Table

Smith Chart

3D Rectangular Plot

30 Rectangular Bar Plot
30 Polar Plot

3D Spherical Plot
Rectangular Contour Plot

Smith Contour Plot

The Report window opens from the Trace tab.
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& Report: GETSTART - EMDesign - Mew Report - Mew Trace(s)

Context

Solution: |F'IanarEI'~"ISE1J.|p1 : Sweep j

Domain: |SWEE|:|

IUpdate Report

[v Real time

Qutput Variables. .. | Dpﬁnns...|

Trace I Families ]

Primary Sweep: |FFEE|

Polar:

Category:

|

Variables

Passivity

OuEut Variables

Quantity: 7

S(pip1)

S(p2,p1)
S(p1,p2)
S(p2,p2)

oy
Range
Function...
Function:

| <norne>____

BC0s
acosh
asin
asinh
atan
atan2
atanh
corjg
cos

cosh
curn_integ
CLm_sum
deriv

EXp

In

log10 v

Mew Report

Close

Note:

The settings described in Step 3 are the default settings in the Report window and it

should not be appropriate to change anything.

3. From the Trace tab, select the following:

a.

b.
c.
d.

Choose a sweep from the Solution drop-down menu (e.g., Planar EM Setup 1 :

Sweep 1).

From the Category list, select S Parameter.
From the Quantity list, select S(p1,p1).
From the Function list, select <none>.

4. Click New Report and the return loss plot opens under the Report window.
5. Close the Report window to view the plot.
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S Parameter Chart 1 EMDesign1 Ansys

90 Curve Info

80
— S{p1p1)
PlanarEMSetup1 - Sweep1

100

-170

-180 =20

-100 80 -80
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Note:

Return to the plot any time from the Project Manager window (i.e., expand the Project
Tree > [active design folder] > Results folder, and double-click the chosen plot).

=[5 GETSTART*
£l EMDesign1*

@ Circuit Elements
@ Boundaries
[-{E3] Excitations
-5 Analysis
E"I Design Verification
{8 Optimetrics
=¥ Results

@ 5 Parameter Plot 1

Ee=]S Parameter Chart 1
..... % Field Overlays
..... Radiation
[#1-[_] Definitions

Continue to Revise An Excitation.

Revise An Excitation

Before creating an overlay of the current results and animating it, alter the edge port definition for
port p2. The default configuration applies an identical 1 volt magnitude excitation at 0 degrees
phase angle to both of the added ports (p7 and p2). Now set the p2 excitation to 0 volts,
essentially making p1 the input of the low pass filter and p2 the output for the purpose of the
overlay.

To revise the p2 excitation:

1. From the Project Manager window, expand the Project Tree > [active design folder]
> Excitations folder. Then double-click p2 to open the Edge Port Definition window.
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Project Manager I =

=13 GETSTART*

L4 EMDesignl*
@ Circuit Elements
@ Boundaries
=53] Excitations

i-988 Analysis

E"I Design Verification
l@ Optimetrics

-5 Results

----- % Field Overlays

----- Radiation

[-|_7) Definitions

(|

+1
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Edge Port Definition d

Port Definition

Port Name: IE

Terminal |
Reference: |g1 j
Calibration Zo: |5I]uhm

PlanarEM

Type: Single Strip Gap Source

[ Ignore Reference

f* Use Port Solver

" Use Default [£0 = 50o0hm]
HFS55
Type: Gap [£0 = 50o0hm]

Post Processing Settings

Magnitude |1'1.I"

Phase |ﬂdﬂ!]

v Renormalize Impedence |5I]uhm + 0i ohm
¥ Deembed Distance [PEM only] |I]mm

[~ Deembed Gap Port Inductance

Ok Cancel |

The Edge Port Definition window provides the following configurable settings:
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Port Definition area:
* Port Name specify the port being defined
« Terminal the name of the terminal (automatic, unfillable field)
» Reference the Port Solver (Reference) used by the port

« Calibration Zo the impedance (equivalent to the Full Port Impedance of the port (in
Ohms))

PlanarEM area
« Type of port (automatic, unfillable field)
» Ignore Reference check to ignore the Port Solver (Reference)

» Use Port Solver select to calculate the characteristicimpedance and propagation
constant of the port. The gap source is automatically calibrated for greater accuracy

« Use Default select if the default setting (expressed in Ohms) is used, instead of the Port
Solver (Reference)

HFSS area

» Type of port (automatic, unfillable field)
Post Processing Settings area

¢ Magnitude expressed in Volts (V)

* Phase expressed in degrees (deg)

* Renormalize Impedance check to use, expressed in ohms

Note:

Even if Renormalize Impedance is checked, renormalization is ignored if it is set to
zero. De-embedding is still honored. However, a warning message appears forall ports
with a zero post-processing renormalization impedance: Zero impedance on port
'<PortName>'is ignored; renormalization is skipped for this port.

+ Deembed Distance (PEM Only) check to use, expressed in millimeters (mm)

+ Deembed Gap Port Inductance check to specify the inductance of the port, which is
calculated and cached as part of the solution data for subsequent use. During post-
processing a list of the ports to deembed is used to calibrate the network data.
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Note:

For more information, refer to Deembedding.

2. Fromthe Post Processing Settings area, enter the following:
a. Inthe Magnitude field, enter OV.
b. Inthe Phase field, enter Odeg.
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Edge Port Definition

Port Definition

Port Name: |p2
Terminal |
Reference: |g1 j
Calibration Zo: |5I]uhm
PlanarEM

Type: Single Strip Gap Source

[ Ignore Reference

f* Use Port Solver

" Use Default [£0 = 50o0hm]
HFS55
Type: Gap [£0 = 50o0hm]

Post Processing Settings

Magnitude |I]'1.I"

Phase |ﬂdﬂ!]

v Renormalize Impedence |5I]uhm + 0i ohm
¥ Deembed Distance [PEM only] |I]mm

[~ Deembed Gap Port Inductance

Ok Cancel |
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3. Click OK to save changes and close the Edge Port Definition window. Repeat for
additional ports.
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Note: Alternatively, use the Port Excitations window to make changes to
multiple ports within the same window. To access the Port Excitations window,
from the Project Manager window, expand the Project Tree and [active
design folder]. Then right-click Excitations and select Port Excitations to
open the Port Excitations window.

Project Manager o x
=] GETSTART*
548 EMDesign1*
@ Circuit Elements
@ Boundaries

el excitations

e Analysis Add Port
.ptl Design veri o
m-'l ==gn Ten Add Plane Wave Excitation
l@ Optimetrics
i ] Results Couple Edge Ports
..... Field Cverl: Decouple Edge Ports
e Radiztion Convert Selected Vias to Coax Probes...

E-(] Definitions A4 Port Excitations...
Differential Pairs...
Recrder Matrix...
Select in Layout
Delete All
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Port Excitations x
Ports
Paort Name Magnitude Phase

Entertext here Entertext here Entertext here

pl 1w (Odeg

p2 o Odeg

deg
HFSS Teminal Excitation {* Incident Viotage ¢ Total Voltage
¥ Include Port Post Processing Effect
Save To File Load From File

oK | Cancel

Continue to Overlay Current Results.

Use Field Overlays

Complete these steps to overlay the magnitude of the surface current results from the trace layer

of the low pass filter.
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1. From the Project Manager window, expand the Project Tree and [active design
folder]. Then right-click Field Overlays and select Plot PEM Fields > Mag_Surfaced to
open the Create Field Plot window.

Project Manager a =
=3 GETSTART*
L-é8 EMDesignl*
@ Circuit Elements
@ Boundaries
]@ Excitations
7988 Analysis
m-i| Design Verification
l@ Optimetrics
- FE] Results

----- % Field Overlays

----- Radiation Plot Fields »

() Definitions Plot PEM Fields ¥ Surfacel

Plot DC Fields Mag_Surfacel
Plot DC Thermal Fields

+1-...I51

I+

Radiation Field...

Plot Mesh...

Marmed Expression...

Modify Plots... Marler

Maedify Plot Attributes...

Set Context To Active Window...

Animate...
Properties Set Plot Defaults...

Open...

Save As...

Delete Plot...

J*  Calculator...
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Create Field Plot

[~ Specify Name ‘Mag_SurfaceJZ Fields Calculator ... ‘

[ Specify Folder |J Surf J Category: |Standard -

Design: EMDesign1 Quantity

Context

SurfacedJ
| Mag SurfaceJ |
Solution: |F'IanarEMSetup1 :Sweej HaRusacs)

Field Type: [PEM Fields -]
Intrinsic Variables
Freq |1.6GHz -

Phase l@ j

Save As Default ‘

[~ Plot on surface only
Nets and Layers

1 71| =no-net=

= <no-ayer=
—|t1

[ Show nets selected

et filter:

Done Cancel
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Note:

The only Solution available is PlanarEMSetup1:Sweep2, since only the
discrete sweep type has the option to output currents.

2. From the Intrinsic Variables area, select 2.1GHz from the Freq (frequency) drop-down
menu. 2.1 GHz most closely corresponds to the point of minimum return loss from the S
Parameter plot.
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Under the Nets and Layers tab, check the t1 box.

Create Field Plot

[~ Specify Name ‘Mag_SurfaceJE Fields Calculator ... ‘

[ Specify Folder |J Surf J Category: |Standard M

Design: EMDesign1 Quantity
Context

SurfaceJ
: Mag Surface |
Solution: |F'IanarEMSetup1 :Sweej LD BINEE

Field Type: [PEM Fields -]

Intrinsic Variables

Freq |2.1GHz -

Phase lm j

Save As Default ‘

[ Plot on surface only

Nets and Layers
A
g
=
o
=
v

B <nodayer> [

[ Show nets selected

Met filter:

Done Cancel

Evaluate the Results (Post-processing) 3-33
Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.




Getting Started with HFSS™ 3D Layout: Low Pass Filter

4. Click Done to save changes and close the Create Field Plot window.

5. If appropriate, refocus from the overlay. From the Project Manager window, expand the
Project Tree > [active design folder] > Field Overlays folder. Then double-click J Surf.

J Surf [Aim]
B.115

pERI
LK)

1.7586

008t

Animated Demonstration

Continue to Modify and Animated Current Overlay.
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Modify and Animate the Current Overlay

Complete these steps to modify a plot legend (colors and scale) and animate the current plot
(i.e., J Surf):

1.

From the Layout tab, double-click in the current plot overlay legend to open the (J Surf)

plot settings window.

J Surf [A/m]
2611581
19.5796
11.0060
6.1866
34776
1.9548
1.0988
06177
0.3472
0.1952

0.1097

0.0617

Evaluate the Results (Post-processing) 3-35

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™ 3D Layout: Low Pass Filter

[GETSTART] EMDesignl -- ] Surf *
Color map lScaIe ] Markerfﬂ.lmw] Plats ]
Type
" Unifam |
" Ramp |
{* Spectrum Rainbow j
Save as default |
v Real time mode Close
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2. Fromthe Color map tab, select Temperature from the Spectrum drop-down menu.

[GETSTART] EMDesignl -- J Surf x

Color map lScaIe | Marker/amow | Plots |

Type

" Uniform |

" Ramp |

{* Spectrum Rainbow j
Rainbow

¥ Real time mode Close
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3. Select the Scale tab and do the following:
a. Inthe Num. Division field, enter 21.
Select Use Limits.
In the Min field, enter 0.1.
In the Max field, enter 26.0.
Select Log (to produce a logarithmic scale).

© 2 o0 T
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[GETSTART] EMDesignl -- J Surf x

Colormap Scale Markerﬂ-‘-rmw] Flots ]

Mum. Division |21 Save as default

O Auto Min: [0.1000
{* |lse Limits Max:  [P6.0000

(" Specify Values |

[ dB Units | A_per_m -

" Linear {*+ |og
Auto Scale Options
[ 4 | digits
MNumber Format
Type: | st j Width: |?

Precision: |4

¥ Real time mode Close

Close the plot settings window.

From the Project Manager window, expand the Project Tree > [active design folder]
> Field Overlays > J Surf. Then right-click Mag_SurfaceJ1 and click Animate to open
the Create Animation Setup window.
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Project Manager o x
J Surf [Alm
=] GETSTART* 2!’-‘, ﬂ{ﬂ]}}
-é® EMDesign1* 19.9514
.[3F] Circuit Elements
@ Boundaries 11.7434
- B3] Excitations
[-388 Analysis 6.9180
..ol Design Verification
l@ Optimetrics orse
-3 Results 23987
[-]ﬁ Field Overlays
EI! 15urf 1.4125
. M Mag_Surfacell
----- ? Radiation Rename F2
[#-(_1 Definitions ¥ Delete Delete
Meodify Plot...
Set Context To Active Window
Export Plot...
Animate...
+  Plot Visibility
Properties Reassign
Select Assi t
Name | Value | Lnit | Evalu St b
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Create Anirnation Setup

Name:|Anhnaﬁun1 Descﬁpﬁun:|

Swept Variable(s) l Design Point l

|Single varizble v |

Start: |D\:|eg

Stop: |1 Tldeg

Steps: |1 7

0K

Cancel

6. From the Swept Variables tab, do the following:

a. Ensure Single variable and Phase are selected from the drop-down menus.

b.
c.

In the Stop field, enter 350deg.
In the Steps field, enter 35.
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Note:

These settings result in an animation with 10° (35deg / 350deg) phase
increments. A 360° phase (360deg) would be identical to the 0° phase, resulting

in a redundant animation frame, and is thus omitted.

Create Anirnation Setup

MName: |Animatiun1 Description:
Swept Variable(s) l Design Poirt |
|Single variable j |F‘hase ﬂ
Start: |D\:|eg
Stop: |35['r‘:|'35|
Steps: |35
0K Cancel

7. Click OK to close the Create Animation Setup window to open an animation control

panel and start the animation in the Layout Editor.
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JSur ]
26,0000
fagtt
117484
69180
4073
2307
14128
0837

0455

02884

Phase = 320deg I

Animation: Animation! -

Al

Frame; 33, Phase = 320deg

l
Speed

Export..
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8. Use the animation controls to reverse, stop, and change the speed of the animation,
among other settings.

Animation: Animaticn — >

Speed
Frame: 13. Phase = 120deq Export...
Close
Label:
Background: Font ¥ Show

9. From the Layout Editor, Zoom, Rotate, or Pan using the standard Layout Editor
controls.
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J Surf [Aim]
26.0000
199514
117484
65180
40738
23%7
14128
08317
04398
02884

0.16%8

01000

Phase = 20deg I

10. From the animation control panel, click Close to end the animation.
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Continue to Create Far Field Plot.

Create Far Field Plot

Far fields are usually not of interest when designing a filter, but the procedure is shown here for
reference. Current outputs are required as the basis of far field computations. To save results,
and current and field results available to plot, satisfy one of the following conditions, then
complete these steps.

* Run a discrete frequency sweep, as follows:
* From the Options area, check the Generate surface current box.

« Specify multiple discrete frequency points and have the current and field results
bavailable for all specified frequencies.

* Define the frequency at which the far field results are viewed.
* Animate the resulting plot. The animation should progress from one frequency to the
next.
e Set up a Planar EM analysis, as follows:

a. Fromthe Planar EM Setup window > Mesh Selection area, choose Standard
Adaptive or Advanced Adaptive.
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PlanarEMSetup1 >

General lOptinns ] Advanced ] Advanced Meshing ] SDI':.rer] Defaults ]

Setup Name: |F‘IanarEMSetup1
Iv Enabled
Mesh Selection
Fixed Mesh | | Standard Adaptive Advanced Adaptive |
Solution Frequency: I5 |GH2 j

Maximum Mumber of Passes: 10
Maximum Magnitude Delta 5: 0.05

| Save curents for last adaptive pass

lIse Defaults

HPC and Analysis Options. ..

| QK | Cancel

b. Check the Save currents for last adaptive pass box. The current and field results
are only available for the last adaptive pass of the specified solution frequency.
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PlanarEMSetupi

General lOptiu:uns ] Advanced ] Advanced Meshing ] Snluer] Defaults ]

Setup Name: |F‘IanarEMSetup1
Iv Enabled
Mesh Selection
Fixed Mesh | | Standard Adaptive Advanced Adaptive |
Solution Frequency: I5 |GH2 j

Maximum Mumber of Passes: 10
Maximum Magnitude Delta 5: 0.05

Iv Save curents for last adaptive pass

lIse Defaults

HPC and Analysis Options. ..

| QK | Cancel

c. Click OK to close the PlanarEMSetup1 window and save changes.

Plot Far Field Results

Complete these steps to set up a far field infinite sphere and plot the results.

1. From the Project Manager window, expand the Project Tree and [active design
folder]. Then right-click Radiation and select Insert Far Field Setup... > Infinite
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Sphere..
Project Manager fx
J Surf [A/m]
=0 GETSTART 26.0000
-d@ EMDesign1 19,9514
.[3F] Circuit Elements
[ &F] Boundaries 11.7484
[#1-[CJ] Excitations
=98 Analysis 8.9180
m-il Design Verification
({8 Optimetrics orse
- Results 23987
EEI'"% Field Overlays
----- b2
-2 Definitions Insert Far Field Setup... > Infinite Sphere...
Insert Mear Field Setup... ] [F |

The Infinite Sphere Setup window opens.
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Infinite Sphere Setup *

Infinite Sphere l Coordinate System ]

Mame Infinite Sphere 1

Phi

Start 180 |deg

E
Stop 180 ldeg v
e

Step Size |2 |deg

Theta
Start ||} |deg ﬂ
Stop |1 ] |deg ﬂ
Step Size |2 |-:Ieg j
Save As Defaults | View Sweep Points... |

QK | Cancel Help

2. Make no changes to the default configuration and click OK to close the Infinite Sphere
window and add the far field setup to the design.
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3. From the Results ribbon, select Far Fields Report > 3D Polar.

g &

P

Browse Solutions

o Clean Up Solutions

Solution MNetwaork ] ]
- Data Data E}{plnrer |mFII:Ir't SUIUUUHS
[EEERER)) m
e AN
2D Stacked MagsAng Polar Data Table
e

.3

b=

3D 30 Rectangul...

—
Fa—

20 Contour

3D Polar

3D Spherical

The Report window opens.

'.E Report: GETSTART - EMDesign1 - Mew Report - Mew Trace(s)

—Context

Solution: IPIanarEMEEmpi : SWEEF'j

Geometry: IInﬁnite Sphere 1

-]

Trace | Families I

Primary Sweep: IThEE

<[

Secondary Sweep: IF‘hi

<[

X ¥ Default I Theta

¥ ¥ Default | Phi

Range

LLLLL 5

& IEb:taI Function...
Category: Quanﬁty:l il I Function:
Variables Etotal M M
Output Variables Ex abs
|ﬁjﬁﬁ_ E 8cos
Gain ¥ acosh
Antenna Params Ez ang_deg
Ephi ang_deg_val
Etheta ang_rad
—Update R t
TN Eright "
W Real time up:hl:e"| Eleft . v
Qutput Variables. .. | Options. .. | Mew Report Apply Trace | Add Trace | Close
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Note:

Alternatively, open the Report window by doing one of the following:

From the Project Manager window, expand the Project Tree and [active
design folder]. Then right-click Results and select Create Far Fields Report >

3D Polar Plot.

Project Manager

= GETSTART*
£ EMDesignl®

@ Boundaries

-- 3] Excitations
988 Analysis

l@ Optimetrics
- T Field O [
? Radiatic
-7 Definitions

pree
Properties

..... @ Circuit Elements

..... m-I' Design Verification

Max: 0.11

012

010

0.08
Paste Ctrl+W

Create Standard Report
Create Far Fields Report
Create Report From File...

Delete All Reports
Report Templates

Uzer Defined Solutions...
Create User Defined Solution

Dataszet Solutions...
Output Variables...

Update All Reports
Open All Reports

Create Document

Perform FFT on Report ..
Perform TDR on Report ...

Rectangular Plot
Rectangular Stacked Plot
Radiation Pattern

Data Table

3D Rectangular Plot

3D Rectangular Bar Plot
30 Polar Plot

30 Spherical Plot

Rectangular Contour Plot
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

From HFSS 3D Layout, select Results > Create Far Fields Report > 3D Polar
Plot.
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STEpE&HE

HF55 3D Layout | Tools

Window Help
Design Settings...

Add Subcircut ?

Port Excitations...
Differential Pairs
Recrder Matrix...
Solution Setup »

Optimetrics Analysis »
HF55 Extents...

List...

Validation Check...

Geometry Check...

Edit Motes...

Analyze F10
Tune...

Submit Job...

Results »

Layout Editor
Schernatic ?
Estimate...

Close Editors

Convert Geometry to Vias...
Select In Layout

Set Temperature

Design Properties...
Design Passed Parameters...

Design Datasets...

Toolkit »

.E i Asis
E Center

Pan Rotate
"EE Cursor

O Fi TR
FtAII m

Animate Copy
Image

[S1

Accumulate Reports

Import Solution...
Browse Solutions...
Optimetrics Results...
Profile...

Matrix Data

Plot Templates

Create Standard Report
Create Far Fields Report
Create Report From File...

Delete All Reports
Report Templates

User Defined Solutions...
Create User Defined Solution

Dataset Solutions...

Output Variables...
Update All Reports
Open All Reports

Create Document

Perform FFT on Report ...
Perform TDR on Report ...

Rectangular Plot
Rectangular Stacked Plot
Radiaticn Pattern

Data Table

30 Rectangular Plot

3D Rectangular Bar Plot
30 Polar Plot

3D Spherical Plot

Rectangular Contour Plot
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

Note:

In Step 4, the Solution and Geometry drop-down menus pre-select the only available
choices that provide far field results (i.e., PlanarEMSetup1: Sweep2 is selected in the
Solution drop-down menu, and Infinite Sphere 1 is selected in the Geometry drop-
down menu) and the lists in the Trace tab pre-select the chosen choices (i.e., Far Field
is selected in the Category list, Etotal is selected in the Quantity list, and <none> is
selected in the Function list).

4. Select the Families tab. From the Families tab > Freq row, click the [...] button in the Edit
column.

E Report: GETSTART - EMDesign1 - Mew Report - Mew Trace(s) hd
Context Trace Families l
Solution: .
|F'IanarEMSE1J.||:|1 ' Sneepﬂ Families : 1 available
Geometry: |Inﬁnite sphere 1 j {* Sweeps ( Available variations
| Variable | Value ‘ Edit |
JFreq 1.6GHz
lUpdate Repart
Morminals: | ﬂ
v Real ime
Output Variables. .. | Options. .. | Mew Report | | | Close
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

A value list opens.

- X
1.7GHz
1.8GHz
1.9GHz
2GHz
2.1GHz
2.2GHz
2.3GHz
2.4GHz
2.5GHz
2.6GHz

Clear Al |

Sweep: (% Default © J

5. Select 2.1GHz, which corresponds closest to the point of minimum return loss. Then click
outside of the value list to close it.

- El
1.6GHz
1.7GHz
1.8GHz
1.9GHz
2GHz
2.2GHz
2.3GHz
2.4GHz
2.5GHz
2.6GHz

Clear all |

Sweep: (% Default © J

6. From the Report window, click New Report and the far field plot opens under the Report
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window. Close the Report window to access the plot.
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7. Close the Report window to view the plot.
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

Note:

Alternatively, open the Report window by doing one of the following:

From the Project Manager window, expand the Project Tree and [active
design folder]. Then right-click Results and select Create Far Fields

Report > 3D Polar Plot.

Project Manager

= GETSTART*
£ EMDesignl®

@ Boundaries

3] Excitations
988 Analysis

l@ Optimetrics

? Radiatic
-7 Definitions

pree
Properties

..... @ Circuit Elements

..... m-I' Design Verification

% Field O [%, Paste

Max: 0.11

012

010

0.08
Ctrl+W

Create Standard Report
Create Far Fields Report
Create Report From File...

Delete All Reports
Report Templates

Uzer Defined Solutions...
Create User Defined Solution

Dataszet Solutions...
Output Variables...

Update All Reports
Open All Reports

Create Document

Perform FFT on Report ..
Perform TDR on Report ...

Rectangular Plot
Rectangular Stacked Plot
Radiation Pattern

Data Table

3D Rectangular Plot

3D Rectangular Bar Plot
30 Polar Plot

30 Spherical Plot

Rectangular Contour Plot
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

From HFSS 3D Layout, select Results > Create Far Fields Report >
3D Polar Plot.
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HF55 3D Layout | Tools  Window  Help
Design Settings... .E i Asis @ orient - @Y Fit Al m R
- § =
Eret 5 Center Add =
Add Subeircuit Fan Rotate % - List Animate  Copy
ursor  Lis
A4 Port Excitations... Image
Differential Pairs
Reorder Matrix...
Solution Setup »
Optimetrics Analysis »
@ HF55 Extents...
BE List.
Q;f.. Validation Check...
@c Geometry Check...
B Edit Motes...
& Analyze F10
s Tune...
Submit Job...
Results > @ Accumulate Reports
8 Layout Editor Import Solution...
Schematic » Browse Solutions...
[ Estimate.. Optimetrics Results...
. .
B’ Close Editors Profile..
Convert Geometry to Vias... [5] Matrix Data
Select In Layout Plot Ternplates 5
Set Temperature Create Standard Report ¥
Design Properties... Create Far Fields Report > Rectangular Plot
. Create Report From File... Rectangular Stacked Plot
Design Passed Parameters... o
Design Datasets... ¥ Delete All Reports Radiation Pattern
Data Table
i ]
Toolkit i Report Templates 30 Rectangular Plot
User Defined Selutions... 3D Rectangular Bar Plot
Create User Defined Solution > 30 Polar Plot
Dataset Solutions... SospenEm
Rectangular Contour Plot
Output Variables... -
Update All Reports
Open All Reports
Create Document >
Perform FFT on Report ...
i Perform TDR on Report ...
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

8. From the Layout Editor, Zoom, Rotate, or Pan the far field plot using the standard

Layout Editor controls.

Max: 0.06 Far Field Plot 1
I 0.06

0.05

0.04

0.03 Etotal (V_per_meter)

glheta (deg)

00 e — _p pa
I 0.01

0.00
Min: 0.00

Etotal (V_per_meter)
r Phi (deg)
g

Ansys

Continue to Overlay Far Field Plot on Model Geometry.

Overlay a Far Field Plot on Model Geometry

To better see how the far field pattern relates to the low pass filter geometry, follow these steps

to overlay the pattern on the model in the Layout Editor.
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

1. Torefocus from the field overlay in the Layout Editor, expand the Project Manager
window > Project Tree > [active design folder] > Field Overlays. Then double-click J
Surf.

Project Manager a x
=l ceTsTART|

i@ EMDesignl*
@ Circuit Elements
@ Boundaries
- [E3] Excitations
i-988 Analysis
E"I Design Verification
l@ Optimetrics
- Results
E% Field Overlays
G- 3 Surf
? Radiation
[-|_7 Definitions

+1....[%]

2. Expand J Surf, then right-click Mag_SurfaceJ1 and select Plot Visibility to remove the
check and the overlay from the design shown in the Layout Editor.
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Project Manager B X
J Surf [A/m
=3 GETSTART* g,lg {H]ﬂ]D
[-é) EMDesign1* 19,9514
@ Circuit Elements
Boundaries 11.7434
[]-- Excitations
-y 69180
I-il Design Verification
@ Optimetrics e
e[ Results 23087
[-]ﬁ Field Overlays
E|! 15urf 14125
&
-y Radiation Rename F2
-] Definitions X Delete Delete
Modify Plat...

Set Context To Active Window L

Export Plot..
Animate...
v PlotViiblty
e S
Properties Select Assignment

Mame |‘u'a|ue| Unit |E1ra|uated‘u’alue| |
Name Mag_..

Solution  Plana...
Phase 0 deg
Freq 21 GHz
Surface 5... |_

The J Surflegend and color contour map are no longer visibile. Making the surface current
results invisible avoids confusion about the values and units of the far field plot overlay.
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P

3. From the Project Manager window, expand the Project Tree > [active design folder]
> Results. Then right-click Far Field Plot 1 and select Show In Modeler Window.
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Project Manager 1 x
=] GETSTART* ! S”F'z.[sm
£-é@ EMDesignl* 19:9514
@ Circuit Elements
[g] Boundaries 11.7454
[-{Ed| Excitations
088 Analysis 6.9180
f’l Design Verification
l@ Optimetrics orse
£ Results 2.3987
-3 5 Parameter Plot 1
(-2 5 Parameter Chart 1 1.4125
i
- Wiy Field Overlays Copy Definition Ctrl+C
- Radiation Copy Data
-2 Definitions [, Paste Ctrl+V
Rename F2
K Delete Delete
Medify Report...
Update Report
Open Report
F‘rn;:lerties_ Report Templates »
Export...
Name Value Animate...
Name |Far Field Plot 1 Show In Modeler Window
Barat Tuna Ear Ealde

4. From the Layout Editor, Zoom, Rotate, or Pan using the standard Layout Editor
controls.
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

Continue to Frequency Animated Far Field Plot.

Animate a Field Plot

Complete these steps to animate the far field plot to see how fields vary with frequency.
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

1. From Window, select Far Field Plot 1 to refocus from the far field plot in the View tab.

Window Help
Mew Window
Cascade
Tile Horizontally
Tile Vertically
Arrange lcons

Close All

~ 1 GETSTART - EMDesignl - Layout
2 GETSTART - EMDesign1 - 5 Parameter Plot 1
3 GETSTART - EMDesignl - 5 Pararneter Chart 1
4 GETSTART - EMDesign1 - Far Field Plot 1

Ctrl+0
Ctrl+1
Ctrl+2

2. Right-clickin the Far Field Plot 1 and select View > Animate to open the Select

Animation window.

Max: 0.11

IO‘\?

0.10

0.06
004

I 0.02

0.00

Min: 0.00

By

P

Far Field Plot 1

Eiotal (V_per_meter)
Theta (deg)
0

1

View

Edit

Modify Report...
Update Report

Save As Template...

¥}  Export..
Copy Image
T

0

Phi (deg)

15

2 OO0 E O

Undo View : Mouse Wheel
Redo View

Rotate

Pan

Zoom

Zoom Area

Zoom In

Zoom Out

Zoom Previous

Fit All

Fit Selection

Hide Selection

Show Only Selection

Show All

Apply Orientation
Add New Onientation...

Animate...

Shift+Drag
Alt+Shift+Drag

Ctrl++
Ctrl+-

Ctrl+D

Ctrl+H

>
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Getting Started with HFSS™ 3D Layout: Low Pass Filter

3. Click Edit to open the Create Animation Setup window.

B Select Animation 4
Animation?2 [Swept variable Freqg New...
Edit...

Delete

1] .4 Cancel

4. Ensure the settings in the Create Animation Setup window match the following example.
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Create Animation 5etup

Name: IAnimatiunE Description: I

Swept Variable(s) | Design Point |
[single varable | | |

Select values:

Pl P P

Z
Z
Z
Z
Z
Z

1] 4 Cancel

5. Click OK to close the Create Animation Setup window and start the animation in the
View tab. Simultaneously, an animation control panel opens.

6. Use the animation controls to Reverse, Stop, and change the speed of the animation, as
chosen.

style="border:1px solid #000000"

7. If appropriate, click+drag the frequency legend to a more desirable location.
8. From the animation control panel, click Close to end the animation.

9. Save the design, either by navigating to File > Save or clicking the Save button on any of
the ribbons.
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=

Save

Congratulations, the HFSS 3D Layout low pass filter getting started guide is complete.
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